Why the motors cut off?

If someone recognizes the Pixhawk tone signal that you can hear 27 seconds into the flight, please tell me what the tones mean. The motors cut off right after the tone, and although the motors restarted quickly, not quick enough to prevent it from crashing on a rooftop.  

Only one prop broke, no matter.  I've flown it again since then and it seems fine.  Another thing happened during that short flight, about the same time as the tone sounded,  in Mission Mission Planner. I got a DCM error, but as far as I know that shouldn't cut the motor off.

I was flying with 3.2 and started in stablize mode and switched to position hold also about the same time as the DCM error and motor cutoff.. Also there appeared to be a discrepancy between the compass and the GPS concerning the way the airframe was orientated, (the compass was wrong, possibly a magnetic field at the takeoff point)

anybody know what the tone means?

Thanks 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Moderator

    Hi Richard,

    I don't recognize the pattern. What version of FW are you using? Do you have log files you can post?

    Regards,

    Nathaniel ~KD2DEY

    • I have a link to the flash file log and also  the Tlog from MP in an earlier post, you can see it under DCM BAD HEADING

      I am running 3.2 firmware.   I will try to link to the flash log, not sure if it will work, The other post shows a video of mission planner screen during the event.

      the flash file is kind of long and the action is towards the end.

      Thanks!

      39.BIN

      • Moderator

        Richard,

        Just taking a really quick look at the log file, if you plot RCIN for CH3, throttle drops to 993 for about 3 seconds around the time you reach peak altitude for the flight. Your RC3_MIN is 992, RC3_MAX is 1997 so the FC is seeing low throttle when the motors seem to stop. If you look at RCOUT for CH1-4 you can see that the FC was outputting about 75% throttle to the motors then when RCIN CH3 drops to 993 the FC sends the motors low to about 1062. This is a bit low but not quite off, THR_MIN is set to 130 so I would have expected it to not drop below 1123 ((RC_MAX-RC_MIN)*.13)+RC_MIN = minimum throttle ((1997-992)*.13)+992 = 1123. Vcc is a little low, but not too bad.

        3702682812?profile=original3702682833?profile=originalCan you post a link to your earlier post?

        Regards,

        Nathaniel ~KD2DEY

        • Thanks Nathaniel

                I will embed a link to the earlier post, and Im glad that you are looking at.  I flew again yesterday, and it seemed like it was handing  little weird, but I was wearing FPV googles and perception is now quite as sharp sometimes. 

          I wanted to do all the preflight pre-prep but I had a snag, my Mission planner wouldn't com up. I generallly like to see the number of sats and the hdop before takeoff. Since MP refused to run, 

          i left it sitting there acquiring for about 5 minutes. The blue light was steady so I decided to give it a go. 

          when I took off, it seemed to drift rapidly to the left, then I had to give right stick to bring it back.  

          I was in Positon Hold when I took off and intended to be.  So the left drift was unexpected.

          Then it began to feel better so I flew it out a little bit, then yawed  180 to look back framing the camera to capture the subject (a construction site).  at that time, I lost video link, so I took off the googles to find the copter.  My spotter helped me find it and I slowly reeled it in. It didn't seem to be able to RTL, and super simple didn't work either, so I just worked with it until I could get the orientation and then landed.

          I found that the SMA connector to the antenna had come apart in the air.. Thus the snow in the googles was explained. 

          As to the weirdness of control when I took off, I copied the flashlog and did a "auto analysis" and there was mention of "a large change in magnetic field"

          I frequently have been taking off from rooftops of large buildings with membrain roofs.

          I wonder if there are large magnetic fields and are causing some problems in getting a good fix.

          Could it have given me the DCM error in the previous post, again, a roof top takeoff from a building with a membrane roof with ironwork below..

          here is the text from the auto analyze:

          attached is a flash log of the flight from yesterday 

          here is a link to my earlier post:

          DCM Bad

          Richard Evans KD5ZZL

          41.BIN

          • I just realized something I didn't catch before, usually in Mission planner when i switch modes, it shows the mode in the HUD.

            I have been switching to position hold, and when I play back the logs, I am seeing that I haven't switched modes, I am stuck in Stabilize.  

            I hooked up the mission planner and wen through the mode setup.  Everything was fine, the modes were set to the right switch positions and the correct buttons became high lighted when I set the switch.  Position hold was the second flight modes, and My Taranis voice said Position Hold and the button lit up  I switched it to Position hold.  

            I realize this sounds like the GPS is not attaining a HDOP value of less than 2.0  

            However, in the planner screen, it was showing 11 sats and hdop of 1.4

            there must be some other value out of waco preventing it from switching to a GPS dependent mode.

            Anybody have and idea what to look at?

            Richard KD5ZZL

            • I have more information about the problem now.. It seems that it is only the position hold mode that the AP will not switch to, I can switch to loiter, and RTL, but not position..

              RE

              • Moderator

                Richard,

                Sorry, it was a working weekend....and I'm still at work. What version of Mission Planner are you using? Is it 1.3.16 (most current)?

                Nathaniel ~KD2DEY

                • Hi Nathaniel

                  I have 1.3.17   I wonder if it could be a bug. I tried to find out where position is mapped to the PWM range, but couldn't find it. (my guess it isn't an easy parameter to find and set as layman like myself.

                  Richard KD5ZZL

                  • I found 1.3.16, removed 1.3.17, and installed the 1.3.16

                    It made no difference.  Position hold can be chosen under flight mode setup, and It doesn't work.  RTL works, and loiter  works they are GPS dependent but Position hold doesn't do anything..

                    very odd.  

                    RE Kd5zzl

                     

                  • I don't think 1.3.17 is beta, It seems to be what I get when I go to the ArduPilot download site "latest version".

                    I have been looking for 1.3.16 to see if it will correct the problem somehow.

                    When discussing "position" I meant "position hold"

                    RE Kd5zzl

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…