I've got one of the new hexacopter kits from JDrones (nice kit Jani, BTW). I've got the copter assembled and I'm running some of the pre-flight tests, but I've run into some problems. Specifically, movement of the pitch stick results in the wrong motor response. If I push forward on the stick, the front motor spins faster. If I push backward on the stick, the back motor spins faster. I've verified the behavior using the "motors" command in the terminal of APM - forward stick makes the back motor spin up, back stick makes the front motor spin up. Roll seems to work exactly as it should (move right, right two motors spin up). Here's what I've checked for possible causes:

 

APM Planner verifies that when I push forward on stick, it is receiving a signal for forward on stick (pulse increases), so signal is not 'reversed'

 

I've double and triple checked that PDB is wired correctly (or at least as specified in the manual). Front motor is fed by output 1, rear motor is controlled by output 2 from

 

APM is facing the right direction - RC pins face motor controlled by channel 2.

 

Any thoughts as to what is causing the problem?

 

An obvious solution would be to just 'reverse' stick direction in either my TX or APM Planner setup, but I'm not sure what problems such a work-around may generate down the road.

 

Thanks in advance for any advice

 

Todd

 

 

Views: 389

Reply to This

Replies to This Discussion

Follow-up:

 

The hand tilt test indicates that the copter acts the way it should, pitching it forward by hand causes the front propellers to spin faster, pitching it back causes the back propellers to spin faster.

 

So I simply reversed the signal from the TX. Movement of the sticks now causes the copter to respond the way it should, and the copter still passes the hand pitch/roll/yaw test. So hopefully the issue is solved (recording here for posterity and future troubleshooters).

 

However, I'm still interested in know if anyone has any insights into why the problem happened, or thoughts on potential problems my work-around may cause in the future.

 

 

depending on your tx it's possible you were using heli mode. I've never made the mistake of putting it in heli mode so I don't know how it responds but remember that quadcopters should be controlled like planes as far as the tx is concerned.

i have a turnigy 9x v2 mode 1 , using it with jdrones latest standard hexa and everything works fine .

Its the same for me .. by default pushing elevator stick forward gets the hexa to go backwards.

 

I assumed its was normal behaviour and  carried on reversing either the stick input .. either at setup via APM MP

or directly on my radio , specifing elevator stick to reverse.

 

Either ways you see it, its not a problem, its more like a feature in some ways (you use your radio with different crafts so arducopter is not faulty here, it just that its default like that and might not be the same for other radios (futaba, JR etcc..)

 

Oh btw  im using acro, not heli or glider ..  and im stuck at finding out how to modify the throttle curve .. those 6x 880kv hmm i find a bit too powerfull to find a confortable stick zone for manual alt hold , sensibility is slightly to high by default .. for me

 

Thanks for the info. I have a turnigy 9x as well, so I'm glad to know that I'm not the only one seeing this problem. I've always used it in acro mode (not heli), and that may be part of it although it's my understanding that you want to use the acro model. 

 

I have the 880kv motors as well, but haven't flown enough to comment on power other than to notice that a little throttle change can result in pretty big change in thrust. I seem to remember seeing something in the settings menu that will let you change the curves (linear by default). Let me know if you figure anything out.

Yup exactly what i mean; Haven't found out yet ; im stuck with a half mysterious "throttle needle" option  .. it looks like its for setting up 4 predefined throttle level points (only) , its not the throttle curve :/

 

looks like only heli mode has throttle curve options, not in acro . Im stuck, as the wiki says you must use your radio in acro mode

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service