Hello guys,

I am building an FPV plane at the moment and want to do crop scouting with it. So I want to use telemtry to upload waypoints and edit the mission etc.

I installed the recent ArduPlane fw (V3.5.2) and calibrated the mandatory hardware. I bought a pair of XBEE Pro 868 MHz modules with RP-SMA connector and set them up via XCTU software.

I set them up with following settings:

Modem VID: 105

Destination Adress high: 0

Destination Adress low: FFFF

Baud Rate: 57600

API off

The Groundstation is set up to Coordinator Enable: Coordinator

The Air end is set up to Coordinator Enable: End device

I can send messages from one XBEE (linked to an Arduino as I have only one SF USB explorer) to the one connected to the PC via SF USB explorer regulated. The board on the air end is an SF explorer regulated board. I see the messages in the XCTU terminal, so the connection seems to be fine.

On the pixhawk side, I wired the explorer board as mentionend on the ardupilor-website (http://ardupilot.org/copter/docs/common-telemetry-xbee.html#common-telemetry-xbee)

Connecting from Mission Planner to pixhawk via USB is no problem. But when I try to connect to pixhawk via XBEE, I see both RSSI-LEDs come on and the RX-LED on the PC-end blinks and also an the air-end you can see the DOUT Led blinks, but Mission Planner always says "No heartbeat" (COM port is selected and baud is set to 57k).

After a few days I was very frustrated that I couln't get it to work so I decided to buy a pair of XBEE Pro S2B 63mW modules to hopefully fix the problem. But it tis still the same.

Both XBEEs are configured and can talk to each other. One is coordinator, the other is end-device.

Does someone have or had the same problem? I have no idea what else I could try to get telemetry to work.

Thanks in advance for your help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • Moderator

          Why did you choose XBees? Thats very old school.

          • Been doing this years, have loads of them lying around and they weren't cheap!

  • Is there nobody, who has an idea how to solve this problem?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
yesterday
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
yesterday
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…