Xbee : Does it work or not ???

there are a few thread's about this.

But ATM my xbee don't work. If i do the test (xbee at terminal and range test) then everything work fine, so the connection between the two modules are ok.

 

Can someone please tell here how to configurate that the xbee's working , so i can do PID tuning without usb Cable.

 

tnx

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • There is unstable connection with USB to ACM. CLI mode is working,  PID tuning is working, but others are not. Sometimes, when you restart board, connection is fine.

    The connection using USB must be more stabile.

     

  • Developer

    AC2 Beta 3 has now MAVLink activated as default. So you don't need to put any extra lines unless you want to use different settings.

     

    Only like what I use for telemetry and XBees is "#define SERIAL3_BAUD  115200" due i'm running my Xbees with 115k speed. Default is 57600.

     

    There are no special tricks to be made to make it working. Just ensure that your XBee's are properly configured and that they are XBee PRO modules. NOT Series 2 as Series 2 has been having problems to stay in connect.

     

    After you get them to talk to each other. It will be easy to use them as telemetry/configuration changes.

     

    Just make sure that all ports/modules are talking with correct speed, your rx/tx cables are in right order, your comport on GCS computer is correct with correct speed, your xbees talks to each other properly.

     

    If you want to be 100% sure about the configurations and you know how to use Arduino IDE, sure you can still put those 3 lines to your APM_Config.h. It does not hurt but as said, they are activated now as default.

  • I'm in the same situation -- I can't get Xbee to work with ArduCopter 2 (Beta 3) and ArdupilotMegaPlanner config.

    I tried and tested the "port 3" test and that worked, but then XBee still does not work with ArduCopter 2 (Beta 3).

    I noticed that for the "port 3" test, I can see the Tx LED on the APM XBee blink, but it doesn't blink at all when I use Arducopter 2 code.

    In an earlier thread, it was suggested that 3 defines need to be added to APM_config.h. In the code I downloaded, those lines exist in config.h. Do I still need to add them to APM_Config.h?

     

    I'm talking about:

    #define GCS_PROTOCOL        GCS_PROTOCOL_MAVLINK
    #define GCS_PORT                  3
    #define SERIAL3_BAUD           57600  (or 115200 depending on your telemetry modems)

     

    Thanks.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…