Xplane 10 sim and APM planner issues

Hi guys

We are desperately looking for assistance with a few issues we have currently with getting our ardupilot setup to function correctly within the simulator (XPLANE10) prior to taking to the field and loosing an airframe and / or more.

Firstly let me apologies that there are a number of questions rolled up in this post, I have tried to make it easier to follow by colour coding the questions in red, bold and italic

The setup is connected as follows: 

Xplane10 is installed on an new Apple Mac Book Pro, connected via a 1gb/s ethernet hub to the windows XP PC running the APM planner - no major problems here, I can fly the simulator using my JR x2610 remote which is obviously feeding through the RC unit connected to the input rail of the ardupilot Mega 2, then via the usb connection to the planner and over the network to my Mac and XPLANE.. 

Radio transmitter is the JRx2610 and Reciever is the R770 that is generally sold with this model

 

The issues:

1) The controls seem to be way out of trim - super sensitive and actually the model plane is only really controllable if I switch to stabilise mode. (which is the only mode other than manual that works) but at least I'm getting comms back and forth.

So I'm assuming some PIDS setup I need to visit - does anyone concur with this? (haven't gotten a chance to adjust these yet and haven't adjusted anything from the default) 

2) Only stabilize and manual modes work ... when I switch to auto, the plane cuts the throttle and banks right heading into a steep dive and crashes, same for all other 'auto' modes.

Any pointers as to where I am going wrong?

3) Only have a two way switch option on my remote so using the planner I alter the flight mode selection to the various options and then trigger it using the two way switch on the remote in order to try them all out - is there another way of doing this ? please point me in the right direction .. 

4) The output to servos window indicates some interesting behaviour that I am not sure is correct - can someone confirm or lend a helping, 'diagnosis' hand - please see the images and notes below:

image :sim1 you can see what I get when looking at the servo output window - the large green movement was me moving the stick.

my question here is, why is the throttle the only channel that seems to be "stable"

and are these fluctuations normal ? - I don't think so...

image : sim2 - notice the fluctuations in the output graph are less violent than in sim 1 - this happens when ever i touch any stick on the remote .. then after about 15-20 secs the fluctuations increase to the size as seen in sim1

image : sim3man_stabilise - This is what I get when I switch from manual to stabilise and back to manual again - 

so it seems to me the outputs should look flat or stable .. is this correct? in which case am I looking at at interference from the TX or power supply ? or something else?

I also noticed in a few posts that the servos "could" move during simulation flying... why don't mine move then .. they did up until I loaded the Sim version of the firmware to the board (which again I'm confused has the same version number as the arduplane v2.50 that was on it before) 

can someone explain the difference between these version please?

 

Thank you all so much for everything that you have done on this project thus far - this technology is already changing the way conservationists do work and will continue to change the way we do our work as it develops into the future... 

Regards

Simon

sim1.jpg

sim2.jpg

sim3man_stabilise.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Simon,

    Still thinking of building the Pioneer?  Hope so.  Anyway, I happened to see your post here.  I doubt I can help much, but I'll point out a few things.

    1.  If you haven't done so already, calibrate your radio on the Configuration page.  I don't recall having to adjust any PIDs due to control sensitivity.

    2.  This problem seems to happen to a lot of people, myself included.  First, on the Simulation page, I had to check Reverse Roll and Reverse Pitch.  I think this was the cause of the plane diving and crashing when switching to Auto mode.

    3.  You don't have to program your switch to test all of the fligt modes.  You can change these from within Mission Planner on the Flight Data page and under the Actions tab.  Use the drop down box to select the mode you want and then click on the "Set Mode" button next to that drop down box.  You can do this while the plane is in flight, whether in simulation or real.

    That's about all I can address.  I hope it helps a little.

    Thanks,
    Paul

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…