Important fix for waypoints

# 1.4.14
* I broke waypoint editing in 1.4.12 - fixed
* Fix problem of not creating temp directories on some tablets
* Fix a couple of rare autobugs
* Sorry Rana: I still haven't figured out what causes UDP upload from the tablet to not work in mission planner (I'm working on another cool APM based project now, when I get back to Andropilot next week I'll fix...)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thank you Kevin. I will try that immediately.

  • Can you add a separate flight modes called "auto take off," "go to waypoint 1," "go to waypoint 2,"...?  This way, you can have more control as to when the arducopter will start its mission and proceed to its waypoints.    

  • What's happening to follow me? has anything been changed?

    Upgraded to 1.4.16.

    I can set GUIDED MODE from Andropilot but Follow me is not working anymore. In the menu instead of "Follow me" or "Lead it" there is a "Start follow me" option ...that in my case is not working. I select the option but copter stays in GUIDED Mode waiting for commands. Goto is working correctly.

    Has anybody tried follow me in 1.4.16 version?


  • Developer

    Hi Wade,

    Alas - that list is all the possible vehicle modes.  The way I intended the user to enter guided is:

    Just long-click on a point on the map.  A small marker will appear then you can click on the menu items to ADD (adds to flight plan) or GOTO (does guided to that position).

    Would you mind entering a bug on the github site (so I don't forget) that says: The "GUIDED" mode should be disabled in the modes list.

  • HI Kevin.  

    I was able to fly for the first time in 2 weeks.  There are a lot of updates that you made.   It looks like some of them are the ones I suggested.   I appreciate that. 

    There was one issue that i had and maybe I just did something wrong.  This is a follow up on the last post.

    What I did is set a waypoints to fly out to the center of the field at about 30 meters of altitude and then loiter.   At that point I selected "guided" from the drop down list.  After that the copter returned to launch and landed.  I tried it three times and it did the same thing all three times. After I selected the guided option I clicked on another place on the map and still same routine.  It should should headed towards the place i clicked on the map. Am I correct?  

    I see that you added the "confirm waypoints"  button I suggested.   I appreciate that. 

    Now Im wondering if that is an extra step in a process like this that may confuse things.   Did you get any other feedback for that.  It sounded good in my head. 



  • Hello

    I was curious what happens if you set a course in Auto mode and then in mid flight of guided waypoints you click the guided mode from the drop down.  Will the drone stop in its tracks and wait for the next command?  I wanted to try it, but would really like to know the result so I know what to expect.  If that is the case than I click a new location on the map for the next stop wil it go to that location at the current altitude or will it go to  to a default attitude and then move to the new position?

    If you or anyone could answer this that would be great.



  • Kevin,


    I confirm the same issues reported by Wade. The HOME location remains at the last coordinates position. Sometimes I had the airplane position (plane icon) in the HOME position, but not the house icon. I needed to close app and reopen it to get my HOME position.



  • It's okay Kevin :) Thanks a lot !

  • Thanks for the update Kevin.   I cant wait to try it.   I have a question: Do you plan to make this as full featured as the Mission Planner that goes on the computer so we can ditch the PC altogether?  Is that in the stars?  it would be cool down the road to be able to calibrate and do the other things that stil need to be done on the PC.   



  • That's great! Just downloaded new version. I'll test it and report asap.

    Thanks a lot Kevin!
This reply was deleted.