Beginner with autotune problems


I finished my new airframe which is much better suited to the extra hardware required for a UAV than my previous attempt. I was successful launching, flying and landing in manual mode. My goal was to autotune, however I must still have something wrong. When I select autotune, the plane goes nose up, then nose down and refuses to allow me to pull out of the dive until I switch back to manual mode. I have attached the logs and I would greatly appreciate it if someone could help me out.

2014-05-22 19-21-54_34.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I have never flown in FBWA. I assumed that I needed to tune the plane before doing much with the other modes.

    • Yes, you should be able to at least double your roll and pitch PIDS, to get good response. Try flying in FBWA to verify if you've got good enough control, and then switch to autotune.

    • Thanks for all the help. I had the elevator reversed in the APM settings. I was using APM Mission Planner and didn't see the options for reverse when calibrating my transmitter. Once I switched to Missino Planner and went through the setup again I discovered the reverse checkbox and it is flying perfectly now.

    • I am brand new to Arduplane so forgive my lack of competence. With that in mind it is nice to know that I am not the only one having this issue, hopefully that means I didn't miss something obvious.

      My PID values are still the default and by max inclination I assume you mean the INT_MAX for Pitch?

      P =.400

      I = .040

      D = 0.032

      INT_MAX = 20.0 degrees

This reply was deleted.