geofence set up error

We seem to be getting a “geo-fence setup error” when turning on the fence since the last arduplane firmware upgrade.We have tried reloading and reading and creating new fences.

Is anybody else seeing that?

What are the conditions that trigger this error?

APM2.5 V3.2.3

MP build 1.1.5593.22505


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    Can you please describe your replication steps exactly and post a screenshot?  Can you also post your geofence waypoint file and we can look at that.

    Thanks, Grant.

    • Hi Grant,

      The error occurs the moment the fence is switch on. The fence we use is one we have been using for the past 18 months. I have noticed from the screen shot you requested that we are in Disarm mode. I believe this error started around the time @Tridge fixed a problem we reported last arduplane upgrade regarding switching to Disarm while still in Auto mode after an autoland. Maybe just a coincidence.

      The steps we take we running through our check list are.

      1. load fence from file

      2. write fence to APM fence from APM

      which all works fine.

      Next time out I will check if Arming first before turning on the fence makes a differnce.

      I'll also try Stephen's suggestion of loading the fence with MAVLINK.




      FENCE_RETALT 100




      Geo-fence error.PNG

      Garrawarra Fence.fen

    • Developer

      Just an FYI the fence file loaded no problem for me in MAVProxy.  Have you had any luck figuring it out?

      Thanks, Grant.

    • Fence loaded ok today after an inital FENCE_ACTION fail to set error.

      Just a couple of things im seeing if anyone can confirm.

      I'm using Mission Planner build 1.1.5633.31488 Arduplane V3.2.1 (54ca5b2f)

      When a fence is loaded but the fence switch is off I get "Geofence Breach" displayed on the HUD but not audio message.

      When fence is on and plane inside fence no fence message is displayed.

      When fence is on and plane is outside  I get altenating messeages "Fence Breach" & "Geofence Breach" on the HUD and audio.

      When the fence is loaded, in Flight Data view the inside of the fence polygon is a translucent white.


    • Hi Grant,
      No luck today at the field. Tried various permutations but always the same error when switching on the fence.
      No I havent tried loading the fence with MAVLink. Will give it a go and let you know.
  • Last time it happened to me it was a bug in Mission Planner that I thought was fixed.  I ended up using a much older version to upload the geofence or used MavProxy.

    • Thanks Stephen,

      I'll try that and let you know.



This reply was deleted.