GPs locking problem

Good evening,I have just bought a apm unit with external Ublox gps unit and external power module,This is being fitted to a Hobby King Bixler 2 PlaneI have done all the Inital setups and calibration as per instructions using the new version apm2 softwareBut unable to get gps lock on the screen or unit.Can any one help with this part of setting or am I missing something out of the advanced settingsI look forward to hearing from you.RegardsNigel Newall

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • The APM sends mosts of the settings to the GPS.

    Maybe your gps is defective, try to connect it with the ublox software and test

    or try this:

    • Morning Paul,
      Are these settings the same for the arducopter apm unit??
    • Nigel, I am sorry but I have to pass on that one

  • Hi Nigel, have you tried sitting the Bix outside with a clear view of the sky for 10-15 minutes?
    You should get a solid red light for power and a flashing blue for GPS lock on the GPS module.
    • Good morning.

      thank you for your reply, I have tried placing it outside  for 10 min and still no lock

      the red light is flashing. for power blue light comes on then goes off.  

    • On the GPS do you have a steady red light?

      The lights on my APM act the same as yours if my GPS is unplugged.

      Recheck your GPS pins & cabling.

This reply was deleted.