Maiden Flight - Flight Mode Weirdness

I maidened my Bixler today with an APM2 running flight software 2.74b and had a couple issues.  The setup is running an external uBlox GPS and 3DR Telemetry radios.  I've got APMs on two multicopters, but this is my first time using it on a fixed wing plane.

Some background - from when I first got the software setup, when I was testing it on the bench, whenever I switch to Loiter or RTL mode (the only flight modes I have setup that use GPS) the 3DR telemetry radio would freeze up.  The green and red lights on both radios would continue blinking, but updates in the Planner would stop.  If I switched flight modes using my transmitter back to Manual or Stabilize the plane would act normally so I assumed (maybe wrongly) that this was an issue with Mission Planner or running it in a VM on my Mac.

Question #1 - Has anyone else seen this lockup behavior with the 3DR radios after using GPS modes?

My first flight started out very well - I took of in manual mode and the plane flew fairly well. It was super-twitchy and if I fly in that mode much I'll set up some D/R and Expo with my transmitter for it.  After I was up in the air and happy with the trims I switched to Stabilized Mode and that worked very well.  I then switched to FBWA and though it was sluggish, and took a LOT of stick to change course, it performed as advertised. 

Feeling good about things, I thought I'd give RTL a shot.  Sure enough, it turned the plane around and headed back to home.  When it got close by, I switched to Loiter and though the loiter circle was very large, it did indeed make a nice big circle above my power-on point.  I then switched back to Stabilize and things got weird - my motor speed went very low.  I tried switching around to all different modes and though I still had control of roll, pitch, and yaw, I had no throttle control in any mode.  Luckily I had space and was able to glide the plane in for a decent landing.  

Question #2 - Why would I have no throttle control after leaving Loiter mode?

I checked then checked the plane over and everything seemed OK.  By hand I verified the stabilization was working and the throttle seemed to be working fine on the ground.  I did not power down the system (in retrospect a mistake).  I took off OK in manual mode, switched to Stabilize when I was just a few feet up, and immediately lost throttle again.  I tried switching modes around, nothing worked and I didn't have enough time or speed to land safely.  I ended up going in nose first, smashing the front of the craft and breaking off a wing.

Question #3 - Why would Stabilize cut throttle?

After all this, I was anxious to look at the logs.  Unfortunately the TLogs stopped recording when I switched to RTL back in the beginning so I had no interesting information there.  Even more unsettling, the flash logs seem to have stopped recording then too.  So I have no log info after switching out of Loiter.

Question #4 - Am I just unlucky?  Why would flash logging stop?  Especially when it seemed like everything was working fine.

I've got some repairs to do, but am anxious to get back out flying again.  I really liked stabilize mode and I can sure see how RTL would be useful.  And of course Auto will be fun.  But I don't like loosing control of the throttle.

2013-08-22 14-53 84.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey Zedtwizt - thanks for responding.

    Chris is a good salesman!

    This board does have some history.  It's a 2.0 board I bought directly from 3DR about a year ago.  When I bought it, on-board logging didn't work so I sent it back to 3DR.  They eventually sent one back which I assumed was a replacement, maybe it was just a repair and there are other problems.  The exchange took quite a while and I bought another one while waiting.  When I got the first one back it went on a shelf until a couple weeks ago.  Maybe it's got more problems.  Visually examining it I don't see any obvious problems, but who knows.

    I flew the plane again yesterday thinking as long as I didn't enter any GPS mode I'd be OK (I really want to fly while we've got good weather!).  I ended up loosing power again and flying into a tree soon after takeoff when switching from STABILIZE to FBWA. I seemed to have some, but not good control over control surfaces, but none over throttle.  And I was locked out of being able to switch modes.

    Looking at the logs afterwards was very interesting.  I had cleared the on-board logs before the flight, but after I finally got the plane out of the tree (maybe 45 min later) there were 20 log files, most of them very short with no data, just header info.  So logging at least is starting and stopping repeatedly.  In none of them could I find the switch out of STABILIZE into FBWA mode.

    Second, I noticed in the first file (leading up to the crash) a bunch of I2C errors (last values in list):

    PM, 42008, 1000, 213, 0, 0, 98, 0, 0, 0, -12544
    PM, 59884, 3000, 51, 0, 0, 43, 1, 0, 1, 4608
    PM, 59833, 3000, 21, 0, 0, 43, 2, 1, 0, 768
    PM, 59833, 3000, 35, 0, 0, 43, 2, 3, 0, -256
    PM, 59865, 3000, 45, 0, 0, 44, 5, 1, 0, 23040
    PM, 59735, 3000, 41, 0, 0, 42, 3, 2, -1, -12544
    PM, 59770, 3000, 43, 0, 0, 43, 4, 3, -2, 13312
    PM, 59808, 3000, 39, 0, 0, 43, 5, 3, -1, 15360
    PM, 59917, 3000, 45, 0, 0, 42, 6, 3, 0, 8192
    PM, 59856, 3000, 44, 0, 0, 44, 7, 4, 0, -12544
    PM, 59882, 3000, 44, 0, 0, 43, 5, 5, -1, 14848
    PM, 59960, 3000, 46, 0, 0, 43, 4, 4, 1, 512

    I find these pretty suspicious.

    I'm 99.9% sure I didn't go into AUTO mode, and there's no evidence of that in the logs.  But of course, it looks like logging was going in and out, who knows what didn't get logged.

    I also had FrSky telemetry on and looked at those logs.  My on-board receiver (powered via the APM rx rails) always had between 5.1 and 5.3 volts power so I don't think it's a bad power issue.

    Right now, it looks to me like either the software on this board is crashing and restarting repeatedly or there's a hardware glitch - which in turn might be causing the software to crash and reboot.

    Because of yesterday's crash, I've got a lot more repairs to make.  This thing is starting to look like a FrankenBixler - thank you APM.  But I'll take the epoxy-drying time to pull a different APM off my quad and see if I get the same errors in the plane environment.

    I also think it's probably stupid flying when anything isn't working right.  I'm not going to try again until everything is working on the bench.

  • 3D Robotics

    Are you using the Power Module? If not, you could be looking at a brownout situation. 

This reply was deleted.