Motors Immediately Spin Upon Powering Plane

This is my initial build of a fixed-wing with APM 2.6.  I power on in Manual mode, and as soon as APM initializes, the motor/prop spins.  Throttle responds to input like it's already armed (it's not) and it will not go below about 10% power?!  ESC is calibrated (about 5 times I've verified the proper calibration).

Now... If I disconnect the ESC from power, and reconnect it, everything is normal?!  Or, if I leave the ESC disconnected and wait until after I start everything up to connect it last, everything is normal.  This only happens when I power everything on together (which is obviously what I want to be able to do).

Anybody have any suggestions?  Thanks in advance for your help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    You may have triggered this bug.

    However, if the motor's are turning on only AFTER the APM has finished starting up then its something else.  If you leave it for a number of seconds does the throttle eventually turn off?

    Otherwise if you could let us know the details of your ESC and attach a log file when it happens (dataflash log would be ideal) we can have a look.

    Thanks, Grant.

    • Thanks for the advice!  I will try to set ARMING_REQUIRE to 2 and see if that fixes it when I get home today.  If not, I will upload a dataflash log of the issue.  

      Your help is much appreciated!

    • Update:

      ARMING_REQUIRE was already set to 2.  So, I tried 1, which is supposed to keep the throttle PWM at 0 until armed, and it worked like a charm.  I don't understand why 2 wouldn't work, because my minimum throttle PWM is set to a value that would leave my motor still, but for whatever reason it was still spinning before arming.

      Problem solved as far as I'm concerned.  Thank you to everyone who helped me out with suggestions.

  • Thanks for weighing in and helping!

    Yes, I am using a power module for APM and a separate BEC for powering servos and such. The ESC I'm using is an OPTO with no internal BEC. I've tried removing the ground and red wire anyways and unfortunately, the problem is the exact same.
  • Does the esc work properly directly off of your receiver (bypassing the APM)?

    You must be using a separate ubec for APM power, is there a chance your ESC internal bec is interfering and provinding some odd reference voltage internal to the esc?  Try pulling your power cable out of your servo connector into the APM and trying again.

This reply was deleted.