Terminal not working in Mission Planner

I need a little help here :)

APM 1280 with Hotel 1.0 Oilpan Downloaded the latest mission planner after I couldn't access terminal in the previous version I had. I've never tried terminal before this. The reason I tried terminal was I added the DIY Drones Compass I just got in the mail and wanted to test it in terminal mode. Everything works as it did before I can still upload new firmware to the APM and it seems to work fine as before in flight data.

I did check the box in hardware and input the declination for my location. I am running windows 7 and everything else seems fine. Except when I try to access terminal I get an initialization message and then it goes into gibberish (a lot of it) If I hit the screen with the mouse and hit enter it hangs the terminal and the planner. I have tried the slide switch doesn't change anything (that I notice)

    What is it I'm doing wrong :) I have read the post here I could find and the manual and I'm not getting it? Everything else seems to be fine just cant get terminal to work.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • there are two things you can chk. the switch on the oilpan should be in setup mode (towards the headers). secondly baud rate should be set to 115200 when connected through USB cable. also do not forget to recalibrate your radio after your burn a new version of APM. good luck!

  • 3D Robotics

    Monroe, you've got one of the old 1280 boards, which were discontinued more than a year ago and do not have enough memory to run the current code. Rather than cut them off entirely, we've had to strip elements out of the code for those boards, and one of those things is the CLI. If you upgraed to a 2560 board, you will get the full functionality.

This reply was deleted.