the 3.3 release note said:it can solve the problem"A number of users had problems with pitch control on auto-takeoff"

but it didn't work on my plane with 3.3.

i found the "nav_pitch_cd" is set to 500 in takeoff.

when the plane takes off in auto mode,the pitch begins to Oscillate.

but in FBWA mode the pitch is controlled well. i think it is not the PID's problem.

can anybody help?3691217859?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had such an oscillation problem when throwing my X5 with aft COG. But when I throw it with a correct CG, which is a matter of millimeter on the X5, it is all good. Also, I never had such a problem when throwing my finwing pinguin. The pinguin behaves like a trainer : a very stable flying behavior. I use ArduPlane 2 (a year old software) with an APM 2.5.

    Hence, I am questioning your Center Of Gravity. Is your plane stable with a safe margin ?

  • Moderator

    Seriously try to DO an autotune, it will most likely fix the problem straight away (assuming that mechanically the plane is 100% sound).

    Oscillation like that is often too high P and incorrect I and D

    • thank you for your reply. your suggestion is very good. I did't do an autotune, but i wonder why the plane can fly well in  FBWA and FBWB even RTL mode.

      I found a way to reduce oscillation: just decrease the "takeoff" waypoint's height from 40m to 10m or smaller.

      this will turn the plane rapidly from takeoff mode into climb mode.(the nav_pitch will change from 5 degrees to 20 degrees)

  • BTW,

    i've calibrated the tube before auto-takeoff. the parameter ARSPD_RATIO is 1.8.
  • Developer

    Could you please attach a dataflash log (.bin) for us to analyse.  Have you done an autotune on the plane?

    Thanks, Grant.

    • Grant, I have another question: If the plane takes off from the hilltop (200 m above sea level) in auto mode.

      can it auto-land in the ground (50 m above sea level)? I want to know how it works.

    • Thank you for your reply, Grant.

      i conducted 2 "auto takeoff and auto landing" tests in June 12th 2015.

      BTW i didn't do an autotune on the plane(just adjust the parameters in manual).  The plane feels good in FBWA and FBWB, even in auto-landing. so i think the PID is suitable.

    • Developer

      I can't access those files.  I get:

      You don't have permission to access "*9phKhFKztIz9MNrjIZsIdB0p*fSgzvBzZijY9CjMl/82_first_wheel_takeoff.rar" on this server.

      Are you able to fix that?

      Thanks, Grant.

    • Grant, i've uploaded the files again. please check

    • Developer

      Nope - I still get the same access denied message.

      Thanks, Grant.

This reply was deleted.