how to modify the default ch3 pwm out?

I am building  a boat with ardurover 2.5 and bidirectional ESC. When i power on Pixhawk first , motor will run at high speed before powering RC. i have check the log file and found there is low pwm output with 1000 and think these is the problem. where i can modify the 1000 to 1500.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Yes,i have calibrated radio. if i power on RC, there is no problem,but when i first power on pixhawk , the motor will run at high speed until rc is truned on .

    • Post your parameter file.  Sound like you may have bound your receiver with a 1000 pwm failsafe but the Pixhawk is unaware that it should go into failsafe mode. 


      David R. Boulanger

    • Hi David, thank you very much. WickedShell says this maybe a bug in pixhawk, but i do not how to modify the code now.



  • Ben,  Have you calibrated your radio?


    David R. Boulanger

This reply was deleted.