[Obs.: The ESC didn't have a Reverse Function so it wasn't compatible with ArduRover Default params, so I've adjusted the RC3_TRIM param in order to disable the Reverse function of the ArduRover]

Hello everyone.

I’m Esteban Caligaris writing from Paraguay.

I’m working in an especial project with ArduPilot. The idea is to build an Autonomous Boat that can detect a special substance.

I’m having troubles in the Autonomous part, because there seems to be a problem in the communication between the Pixhawk and my ESC (My ESC: Turnigy Plush-40A, with an incorporate BEC-3A/5V-Version3.1).

What have I done so far? First of all, I have uploaded the last Firmware Available of ArduRover and then gave it a try.

I found out that the Sticker for APM-Rover it doesn’t match with the Latest Firmware. The Steering Output it’s marked at the Main Out number 4, when it actually the Servo for Steering works on the Main Out number 1 (Found out that by trial and error, because my servo didn’t seem to work in the “correct” place and gave it a try with the PX4 Connection Configuration).

Now, my real problem it’s that I can’t manage to start up my motor, and it seems to be that my ESC it’s entering in a Programming Software and I can’t make him to finish it.

I’m working without RC-Transmitter and Receiver, setting the Params for the Pixhawk in order to predefine Auto Mode as the Initial Mode.

My Params:

                INITIAL_MODE: 10 (AUTO)

                CRUISE_SPEED: 20 (20 m/s)

                THR_MAX: 100 (100% of Throttle)

                CRUISE_THROTTLE: 0 %, in a first try and CRUISE_THROTTLE: 100 %, in a second try

                RC3_MIN: 1200, in a first try and RC3_MIN: 800, in a second try.

                RC3_MAX: 1900, in a first try and RC3_MAX: 1800, in a second try.

Here’s a Video of what kind of problems am having.


And here are some Pictures of what I’m working for.




Thanks for reading and for helping.

Esteban Caligaris

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • @TCIII, @David, @Grant

       I have really really really good news!
       I have solved the problems!
       I solved it by setting the RC3_TRIM param at 1100, matching with RC3_MIN param.

       Thanks for the help.

       Greetings from Paraguay

          Esteban Caligaris

    • Developer

      That's great.  That would mean your ESC doesn't have reverse (or its disabled) I would suggest.

      Thanks, Grant.

    • I'll be posting my Ardu Boat Project soon.


  • Admin


    Does your ESC have forward and reverse or is it forward only? The ArduBoat firmware is expecting an ESC that has 1500us as neutral, 2000us as full forward and 1000us as full reverse.

    Videos are okay, but I suggest that you provide tlogs and/or dataflash logs to help troubleshoot your issue.

    Also, I suggest that you first get the boat to work properly in the Manual Mode and then move on to the Auto Mode. If it will not steer and run properly in the Manual Mode you cannot expect it to perform correctly in the Auto Mode.



    • I looked up this Plush ESC and I don't think it has reverse.  Its probably going into calibration mode right off the bat because it is not getting a low PWM at start up.


      David R. Boulanger

    • Admin


      Nice find. Yes, the firmware puts out a 1500us neutral PWM signal when the Pixhawk is armed.

      I always wait until I arm my Pixhawk before I energize the ESC so it will see the neutral PWM signal when it starts up.

      I would not recommend using a plane/multicopter ESC in either a R/C car or boat as you can get into a situation where you need reverse and do not have it:-(

      Also, not using an R/C transmitter with the boat is just asking for trouble because if you get a runaway (they do happen) in the Auto Mode you have no way to take immediate control by switching to the Manual Mode.



    • @TCIII


      I’m really appreciated for your replies. And what ESC and Motor do you recommend to use?

      Esteban Caligaris

    • Admin


      Since your catamaran appears to be big and heavy (how long and heavy is it?) you are going to need a big brushless motor for propulsion and a big servo for steering.

      My Autonomous Boat Project will give you an idea of the size of motor and servo required for a 46" long boat that weighs about 20 pounds without the batteries. It is designed to have a maximum speed of around 30 mph which is probably much more than you need. Hopefully this will give you an idea of how to scale your motor and servo to the size of your catamaran and its required speed.


      TCIII AVD  

    • @TCIII

      You're right. My catamaran is relatively big (98cm long - 38,54" long) but weights 2760g (6,08 pounds) with the electronics components.

      I'm planning to use this Servo:


      And this Motor: (Still not completely sure about the motor - should I choose one with higher KV? or higher Watts? or higher KV and Watts?)


      I'm practicing with the components of the Video. I haven't bought the motor yet, so a friend lent me his airplane motor and ESC.



    • Esteban,

      My thoughts are:

      Have you thought about using Blue Robotics thrusters?  Your design will be a displacement hull and not a speed demon.  It should move along at 2 - 2.5 knots relatively efficient from a power stand point.  See my build in the link below.  I learned a lot building this and would do a few things differently if I was to build another one but it performs reasonably well.



      David R. Boulanger

This reply was deleted.