Need help with Acro flight mode- very lagged response

I'm in the process of tuning my 4 bladed, 10 lb helicopter. I have the rate_xxx_p gains high enough that the Heli responds nicely in stabilize mode but when trying to fly in acro mode, the aircraft response is very lagged to my inputs. Even with rotors static, you can see the swashplate response is lagged in acro but not in stabilize. Here are my settingsATC_RATE_RP_MAX=36000ATC_ACCEL_RP_MAX=162000ATC_RATE_FF_ENABLE=1RATE_ROLL_P=0.13RATE_PIT_P=0.13RATE_ROLL_D=0RATE_PIT_D=0RATE_ROLL_I=0RATE_PIT_I=0RATE_ROLL_FF=0.02RATE_PIT_FF=0.02ACRO_RP_P=4.5ACRO_EXPO=0ACRO_TRAINER=0If anyone can shed some insight, I would greatly appreciate it.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    maybe RC_FEEL is set too low?  Try setting to 100?  Just a guess.  Best to post a log.

    • Randy,

        Thanks for the response.  Here is a log from a flight I did earlier today.  I had increased the ATC rate and Accel max parameters because i thought the rate and accel limiting was causing the lag.  I was using the channel 6 option to vary RATE_RP_P gain.  It seemed like ACRO was responding better but still significant lag that was unacceptable.

      First arming
        ATC_ACCEL MAX 144000 
        ATC_RATE_MAX 36000
        Tune RATE RP_P low 0.01
        Tune RATE RP_P high 0.08
      First hop mainly ACRO  with a short hover in Stabilize at the end
      second arming
        ATC_ACCEL MAX 162000 
        ATC_RATE_MAX 36000
        Tune RATE RP_P low 0.07
        Tune RATE RP_P high 0.16
      Mainly Stabilize with a little ACRO in middle.  Reached RATE_RP_P of 0.11 at end of flight

      2015-11-08 09-27-03.bin

This reply was deleted.