Pixhawk hardware test

Hello everybody,

So a year later and this new pixhawk I purchased still has yet to work.

Unfortunately I have always had an issue with the board, it never accepted any rc signal. I've tried swapping the board out for a another one in my setup and it worked flawlessly, however my first pixhawk has never worked (its a authentic 3DR pixhawk).
I've tried every trouble shooting method possible according to a 3DR engineer, and am told the board would need to be tested or diagnosed to se what the problem may be.
So does any one have any idea what so ever on how to diagnose the issue? What are some hardware tests I can fun in order to determine what is the issue causing the disconnect and prevent any RC IN signal recognition? I checked voltage between the possible and negative pin on the RC IN port on the pixhawk and I do get 4.70v when connected via usb. I've literally tried every setup scenario plausible, even using encoders to converters, but like mentioned before my secondary pixhawk worked flawless since I got it without the need for any encoder, converters or anything.
So any hardware help would greatly be appreciated, and if there's anyone in the Ontario Canada region who may be able to offer help, I'd be more than grateful!
Thanks for any and all help,
Craig P.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –