Hello Follks,

I recently ran into a reoccurring problem with my original pixhawk I purchased from a Canadian distributor, and since day 1 I have consistent RC connection issues, although I did manage to resolved the problem with a ppm encoder after many many weeks, I was never able to get any function or rc signal from an X8R to the pixhawk through sbus. My remote is a turnigy 9xr (XJT module), and although the ppm encoder did work I always felt it should not be required after all the pixhawk has sbus support direct, but thats not the issue, I had switched to an cppm sbus converter to the pixhawk and it also worked (well at first anyway). Then over the holidays I attempted to update the pixhawk the the newest firmware and run through all my calibrations (I added a gps mast so wanted to make sure everything was on point), and upon doing so I could not longer receive any RC signal once again (the nightmare problem decided to shows it ugly self once again). So upon looking for my ppm encoder to test to make sure it was not merely the sbus converter giving me issues I could no longer find it. So instead I caved and ordered a completely new pixhawk from 3dr robotics and within seconds with no effort and no converter or encoders I got signal from the x8r direct from sbus. This is the same exact setup as I previously had. So it leaves me to believe that it is in fact the pixhawk which is giving me the problems. Now this was one of the first pixhawks as I did order it march of 2014 from the Canadian retailer, which did come with the 1gb px4 Autopilot sd card which seem to be causing everyone issues so I did switch to a 16gb SanDisk Ultra.

So my questions is what could be causing these issues? Perhaps a faulty signal pin connection on the pixhawk? (this doesn't seem probable as it has worked in the past) Or could it be a more programming problem that some method of completely resetting the pixhawks memory may fix? Or is it safe to say this pixhawk is ready for retirement unless I attempt to purchase another ppm encoder and try that. (It did run great when it would work although even a ppm encoder was difficult and tricky to get working and I can remember what it exactly entailed). Or finally is there some recommended test or method to figure out what is truly the issue? I should note that I have tried going from Adruplane back to Adrucopter and still no avail?

Thanks in Advance.

Craig P.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –