APM 2.6 connection error to Mission Planner

Hi all,

I couldn't connect the APM 2.6 to mission planner. I don't know where the mistake is ? I downloaded the latest version of Mission Planner and plugged the APM 2.6 to the PC then I chose "Install Firmware" and firmware was installed. Next, I chose the "APM Copter v3.3.3 Hexa". When the process bar is done, I cliked to the connect button located right-hand top of the Mission Planner. It was almost done but it failed as giving the error that " You cannot load new firmware while connected via MAVLink. Please press the disconnect button at top right to end the current MAVLink session and enable the firmware loading screen". Then,of course, I disconnected it and searched for the enabling the firmware loading screen but i couldnt understand what the meaning of it is. Can you help me about it?



You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


  • Yes you need to be disconnected from Mavlink.

    Go to your PC control panel then to Devices and printers. You should see the APM listed as Ardurino 2560 or something like this.This will tell you the com port and baud rate (communication speed).

    The mission planner has to be  set up to match the com port and speed. You can change Mission Planner to match.

    • Hİ Paul,

      I checked that now. It is connected to COM9 port and the baud rate is 9600. I set up the mission planner to do so. This time, another different error popped up says " Connect Failed"

    • My APM connect at 115200 baud with USB, try there

    • You can get 3.2.1 here: http://firmware.ardupilot.org/Copter/stable/apm2-hexa/

      Save it to your computer

      Stay out of Device Manager.

      Start Close Mission Planner.

      Connect the APM to your computer.

      Windows will "happy beep" when the APM is detected.

      Launch Mission Planner.  DO NOT CLICK CONNECT.

      Click Initial Setup


      Click Load Custom Firmware.

      Navigate to the copy of 3.2.1 and double click the file.

      Mission planner will connect to the APM and install the firmware.

      When the firmware installation finishes you must physically disconnect (Unplug)  the APM and then reconnect it.

      As for your serial port settings, by default the APM USB port is set to 115200 baud, and Telemetry radios are set to 57600 baud.

      ArduPilot firmware : /Copter/stable/apm2-hexa
    • Thank you, Clifton,

      It worked.

  • You have installed the wrong firmware.  3.2.1 is THE LAST VERSION FOR APM.

    You need to start all over from the beginning.

    Install the firmware for an airplane. This will overwrite Copter 3.3.3.

    Install Copter 3.2.1 Hexa.

    • I've just uninstall tlhe Mission Planner and then I'he gone to http://planner.ardupilot.com/wiki/common-install-mission-planner/ and I downloaded the latest Mission Planner. And I faced with " APM:COPTER V3.3.3 Hexa " again. Now should I click the  "Pick Previous Firmware" ?

    • Click "Previous Firmware" then select 3.2.1  (i thnk i highlighted the wrong firmware, not sure but you get the idea)



    • Hi Micheal,

      I just did what you said. This time I saw the APM:Copter  V3.3.1 Hexa.  And the same error popped up again. :((

    • try downloading it from here:  http://firmware.diydrones.com/Copter/stable/apm2-hexa/ and then load custom firmware. hope this works for you.

This reply was deleted.