APM 3.1 and all flight modes unknown?

I updated to APM3.1 last night and went through the whole setup process. But i noticed in Mission Planner, APM Planner 2, and Droid planner all of my flight modes show up as "Unknown".

It appears to be switching into correct modes by the sound of the motors (no rotors) when i put it in loiter and move it around vs put it in stabilize.

I can grab some logs tonight if that would help anything. Or is this a known issue? I didnt find anything off google regarding it.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I am building a xxhawk drone and having the same problem when I go to assign flight mode in mission planner

    the dropdown boxes are empty. this is 3.2.1 right out of the box.

    • I had the same problem. It's a Mission Planner problem; not the APM. I downloaded the mission planner several times and reinstalled, but no luck.

      Then I uninstalled MP and deleted all the files in the MP directory (C:\Program Files (x86)\Mission Planner). Then reinstalled. Then it was ok.

    • I did the same thing and it worked. Now my bro values in parameters will not stay loaded. Not sure how to fix this. I am using a teensy 3.1 and cannot test it without the proper bro values loaded.

  • I have the same problem on a windows tablet running windows 8.1 and MP 1.3.34 

    All flight-modes are working ok in flight but not shown in the MP.

    Genuine 3Dr Pixhawk in the other end running latest fw. all works ok with my other PC and windows 10.

    Any working cure for this problem...??

    • I now tried to upgrade my Windows tablet to Windows 10 and reinstalled MP still flightmodes unknown...Works ok on my laktos computer with Windows 10.
  • Has this issue been resolved yet ?

    • I have now got a APM2.6 clone. Same issue . So nothing to do with Hardware. Firmware 3.2.1 or MP

      Anybody ??????

    • Developer

      It's the mission planner that is the problem.  The short-cut solution is to go to the flight data screen, press Ctrl-F.  Select Paramgen, wait 3 minutes or so and restart the mission planner.

    • Yes. Definitely a Mission Planner problem. I have installed MP on 3 different (all Windows 7) computers and tried different versions. At the moment, I'm running v. 1.3.16 on two of them. One is working perfect. On the other, several of the forms are not fully populated (see screen captures)




      The rest of the forms seems to be ok.

      I have tried the "Ctrl+F" trick on this computer, but no change. I have also tried reinstalling several times and also different versions. No luck.

      I have used the same computer last year with no problems (cannot remember what version then)

  • My APM2.0 was working fine with MP 3.1 today. Then next time I connected. All Modes are blank. All flight modes showing as Unknown.... strange.

This reply was deleted.