APM 3.1 and all flight modes unknown?

I updated to APM3.1 last night and went through the whole setup process. But i noticed in Mission Planner, APM Planner 2, and Droid planner all of my flight modes show up as "Unknown".

It appears to be switching into correct modes by the sound of the motors (no rotors) when i put it in loiter and move it around vs put it in stabilize.

I can grab some logs tonight if that would help anything. Or is this a known issue? I didnt find anything off google regarding it.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,MBerry,

  • aside from droidplanner not displaying modes with 3.1 neither does my minimosd. Can see status ok in Mission Planner though. 

  • Developer
    In APM Planner 2.0, you can easily debug MAVLink messages by going ti the menu and select Advanced Mode. Then from the Tools Widget Menu items open the MAVLink inspector. This will show you what messages you are receiving, frequency and values.

    What frequency is the hearbeat message being updated?

    See https://pixhawk.ethz.ch/mavlink/#HEARTBEAT
  • I am having a similar problem using 3.1 but only with droid planner. I have 2 apm 2.5 boards, one with 2.9 and one with 3.1 and the 2.9 has no issues. something with 3.1 is causing the mode not to display in droid planner. Mission Planner works fine.

  • going through the terminal i ran setup > modes and it shows the mode name, and switching as expected from my radio.

    reflashed to 3.1, still unknown modes. flashed to a beta, still unknown modes. re-installed Mission Planner, still unknown modes...

    yeah...I have no clue what happened.

  • Im thinking it's beyond mission planner. I get the same issue on my nexus, windows 7, and OSX mavericks. And with USB or the 3dr radio telemetry.

    I'm thinking about reflashing my APM. I ran out of time to play with it last night. Is there a way to see the current flight mode from the terminal? I'm wondering what the mavlink message looks like.
  • Please, update status of the issue!!!

  • Developer

    I've never heard of this from anyone.  Maybe reinstalling the mission planner is in order?

This reply was deleted.