ESC Calibration

Hi All

I have been struggling with this for a few months on and off but I have been at it full on this past week and I have got nowhere!! 

I go through all the usual steps and after the long monotone note, I press the arm button and noises are made, wait for them to stop then move the throttle down to low and it is recognised,THEN the strange bit, about 10% of the time 1 of the motors will correctly calibrate. I have had 2 motors correctly calibrated at once as my personal best and all of the motors do spin they just do it in pairs! I would really appreciate any help any of you can suggest.

Many Thanks


This is my set up as it would be useful for anyone who could help:

Tunrigy 9x + the encoder that gets it to work on the pixhawk

4 Turnigy D2836/9 950KV motors

4 HobbyKing 30A UBEC (

3DR power distribution board 

1 Turnigy 2200mAh Li-Po battery 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi James,

    From what I can see you are going to have to follow HobbyKings instructions for calibration. At this point you may want to looking into flashing the ESC/UBEC with SimonK. It looks like that is possible. You should have better luck with the SimonK firmware. 

    Sorry I can't be of more help!

    Take care,


  • Thank you all very much, I had attempted individual calibration but these steps are a lot more detailed so I will give them a go when I next can and keep you updated.

    • Don't mean to hijack, but I have a similar issue and haven't been able to find how to resolve it. I calibrated my ESCs manually by attaching directly to the receiver (FrSky Taranis X8R) and I can control the motors this way. When I connect the ESCs to the outputs of the Pixhawk, I get nothing. I can enter the calibration mode with the Pixhawk and get the long tone, but it never registers the high side of the throttle input. I did press the safety button and it was solid red like the instructions and videos indicate. Not sure what else to try. ESCs are Range Video ZTW Spider 40A 600Hz Opto.

      I've double checked my throttle failsafe value (shouldn't matter when throttle is high) and min/max values as well as tried changing the ESC Update Rate (RC_Speed) anywhere from 50 - 200Hz and still get nothing. Radio calibration and everything seems just fine (using SBus output to RC Input of Pixhawk), just not able to get motors to respond when ESCs are connected to Pixhawk. I have the PWM module, but haven't tried it yet. Don't think I should need it since radio calibration worked and the Pixhawk will arm/disarm and enter ESC calibration mode. It seems to recognize the proper signals.

      I saw something about connecting ground wires of ESCs directly to Pixhawk - can someone explain exactly where? I have all ESCs and Power Module from Pixhawk connected to a Power Dist. Board (PDB) so all ESCs see battery voltage. This also provides the 5v necessary for the receiver - Taranis actually reports 4.5V on the display. The ESCs are connected to the motor outputs of the Pixhawk using the standard servo plugs - power, ground and signal. This should take care of all connections necessary, right? I can't see where another ground connection would come into play.

      Any ideas? Thanks for any insight, I hope this helps both I and the original poster, and any other others down the road....

    • Correction - when plugged into usb and configuring with mission planner, the Rx voltage is 4.5V (USB power); When connected with my battery pack, the radio indicates 4.76V and holds steady reagardless of stick movements.

  • Developer

    Yes, I totally agree with the advice from Erik and Robert.  Take the pixhawk out of the loop and do the calibration one-by-one directly with the receiver.

    • Im also having these sync issues.

      Noob question, how do you power the receiver without the flight controller? 

      Do we not need to worry about voltage on the receiver? I always assumed the pixhawk would regulate the power to the receiver (again, apologies for noob-ness)

    • You either use the power from the ESC or if you need to you can use a 5v battery pack and attach the ground (GND or - ) which should be the black wire to ground pin on the receiver. Then attach the 5v ( + ) red wire to the corresponding pin on the receiver. Connect both wires to any channel on the receiver but make sure both wires are connected to the same channel (it shouldn't matter but I can't guaranty it doesn't I just ran into a situation where it did.) The simplest way is to just use the power of the esc of the motor under test/calibration.


  • Try calibrating each ESC by itself. Simply disconnect the esc cables from your flight controller and then plug  each esc directly into channel 3 on the bond receiver. follow the instructions about the throttle fully extended power on listen to the sounds etc...

    Then move on to the next.

    This will fully calibrate the ESCs. If you have problems with this then there is something wrong with your ESCs.

  • Hi James,

    After looking at the user manual of your ESC, (on the Hobbyking site, under files tab), you can find in the larger manual that these ESC do have their own settings you will need to program...
    Programming is done by moving throttle sticks to the max, and then depending on a menu, which is explained to min value as well.

    As you are trying the ESC calibration by using the calibrate All at ones option in the PIXHAWK you may run into a situation that the ESC itself is also setting values....

    To prevent this I would first focus on the ESC's and make sure that their default value's are set correctly, by taking the PIXHAWK out of the equation.

    Just use your receiver (without the PPM decoder) and use you throttle out channel to feed into the EsC.

    Then set all ESC values the same, so no brakes, same settings on all other options (of all the ESC's)

    After that you reconnect the PIXHAWK, PPM encoder, and make a note of the min and max value's in the radio calibration screen...
    If for what ever reason your max value's are not high enough the ESC will not recognize the max throttle as calibration value, which could explain that only two of your ESC calibrate...

    I also know that the PPM decoder is reducing the max and min value's if you compare this with the value's which are coming directly from the receiver, so you may be not reaching the required max values for your ESC....

    I hope you did radio calibration before attempting to Calibrate the ESC's with the PIXHAWK

    If this all will not get them calibrated you may need to reflash the ESC's with the SimonK code, which is specifically for multi rotors...

    It takes out all the options which are now in your ESC's.....

    Good luck,

This reply was deleted.