Failsafe on Spektrum DX6i

Is it possible to configure failsafe with a Specktrum DX6i?

I did the binding process with the transmitter set as it would be for RTL mode but when I turn the transmitter off as a test Mission Planner tells me the mode has switched to 'loiter'. I actually tested that by flying my 3DR quad away from me, hovering about a meter off the ground and then turning off the transmitter. The copter just fell to the ground when the motors stopped.

The manual for the TX says that the AR6200 receiver I'm using includes their 'Smart Safe fail safe system' which establishes low-throttle fail safe if the RF signal is lost. Is this the issue? Am I correct in thinking that their are two conditions required to trip failsafe in the APM, low throttle and no signal? If so and the receiver automatically goes to low-throttle then wouldn't that mean that my receiver can not create the conditions required for the APM to initiate failsafe? If so, I guess that changing the receiver would be the way to go right?

I have a new AR6210 here as well but haven't read the doco for it yet.

TIA for help with this.

Cheers from DownUnder and Happy Holidays to you all.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Writing this to the best of my knowledge since I have AR6200 and AR8000

    The AR6200 will not engage any switches as preset, I use a AR8000 for this.  

    So to me there is no way to bind the transmitter to RTL mode and im not sure how you saw it change to loiter.

    The throttle is the only thing that can be programmed with the AR6200

    I have a two AR6200 and one AR8000

    If you want to get some type of failsafe in the 6200 you can only get a soft land.  Find where your throttle lands the craft in a somewhat safe manner.  Bind it with the stick in that position and if you ever lost signal it will land where its at.  But none of my AR6200s have ever been able to RTH or RTL because it wont throw the switch.

    Hope this helps Ed,

  • I have a Spektrum DX7s with AR8000 receiver, so my knowledge applies to this pair - and should hopefully apply to yours. 

    Out of the box, my TX had a lower limit of around 1100 PWM - as confirmed in the APM Planner. One of the RX/TX failesafe modes is to set the throttle to specific PWM on loss of signal. Obviously, you do not want that during normal operation (see my first posting), so this value should be outside of your normal throttle range. I set up my failsafe as follows:

    1. Programmed the TX and changed the lower limit to a PWM of 900, in the Throttle Curve sub-menu
    2. I enabled the preset failsafe (on signal loss, all channels are set to their failsafe position):
      1. Insert bind plug and power on RX
      2. Remove the bind plug when the RX LEDs start flashing.
      3. Move throttle to lowest position, leaving everything else centered
      4. Turn on TX while holding the Trainer button - to tell the TX to enter bind mode.
      5. After 15 seconds, they should be bound
    3. Re-programmed the TX to change the lower limit back to 1100, and re-calibrated the Radio in the APM Planner.
    4. Set throttle failsafe to 900 in APM Planner.

    Under normal operations - when TX and RX are in range of each other - the APM failsafe should never be kicked in, since the lowest throttle PWM that the APM will receive is 1100. Only when signal is lost, will the RX send a PWM of 900 to the APM, to indicate that it must go into failsafe.

    Hope this helps you.

This reply was deleted.