Problem with Hexacopter using APM 2.8


I recently purchased a Tarot 690s hexacopter , it was partially assembled (e.i the ESCs and UBEC were already soldered to the PDB). The Flight controller is an Arducopter APM 2.8 and the TX/RX combo is The RadioLink AT10 and RadioLink R10D. The problem I have is, upon take-off the copter immediately tips over backwards and the rear props hit the ground. I've tried everything I can think of. Double checked the props and motor rotation, the signal inputs and outputs,  everything. Reinstalled the firmware for the APM. Updated the firmware for the transmitter. Still, nothing worked.One would think that you could just trim something like that out with the Transmitter, but I tried it. This led to the discovery that the copter isn't responding to any input other than the throttle. It doesn't respond to the yaw, pitch, or roll inputs from the transmitter. Nor does it react to its own internal gyros or potentiometers, when you tip or rotate it manually. Nothing but the throttle. In mission planner it shows the the transmitter is sending all of the signals to the apm, but it doesn't react to them. I don't know how to fix this at all.

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


    • Okay, throttle Max set to 1000, and everything appears to be working correctly on the ground. I'll see if I can get out and test flight today.

    • I don't see anything fundamentally wrong, but I would be inclined to power the APM from the BEC first, then power the receiver from the APM.  That will keep the APM ground currents from interfering with the receiver channel signals.  

      I don't know why the USB power is needed to make the controls work correctly?  This is indeed a mystery.  Re-do the order of power, BEC --> APM --> Receiver, then see what happens.


    • Hmm, I couldn't reply to your last post for some reason.

      Anywho this is what's going on.

      This is all done in "Stabilize" flight mode.

      Once I calibrate everything, including the ECSs, after plugging in for the first time after the ESC calibration it goes through the whole start up process. The initial 3 beeps, followed by 4 beeps which I assume is it counting the battery cells, then one long beep and in a few seconds it's ready to ARM.

      I ARM then throttle up to about 25%, the motors come to life Quickly revving to about 12% then slowly speeding up.

      Then I throttle up to about 40%. the motors have been slowly revving higher until about this point.

      I throttle up to about 50% the motors hold steady at about 40%.

      The motors continue to hold that steady rate through 60%, 75% and 100% and all the way back down the throttle range until the the throttle is completely bottomed, at which point they stop.

      The only change in motor speed now comes from the yaw, pitch and roll commands from the TX or from it detecting manual movement from it accelerators.

      I tipped and rotated it in every direction I could think of to get log data that I'd never be able to make sense of.

      Then I set it back on the floor, allowed it to DISARM then disconnected the battery and retrieved the attached log file.

      I'm not sure if it's actually supposed to act this way since it's probably responding to the fact that it can't change it's position when the motors are turning.

      I was tempted to attach props and flight test it, but I was afraid it'd fly away or I'd eventually have to cut throttle and crash it since I apparently have no control over motor speed now.

      2016-04-26 20-35-07.bin

    • One more thing - the AMP will disarm the motors automatically if the throttle is low (all the way down).  The default time to disarm is 10 seconds I think.  Is that what was happening below? 

    • If I recall, you have to disconnect the battery at the end of the ESC calibration to lock in the numbers - that is normal.  Do all of the other calibrations first, Including the radio calibration, then follow this procedure exactly for the ESC calibration ending with unplugging the battery:

      Also, what mode are you arming the copter in?  If you are in Altitude Hold mode, the motors will not power up completely until the throttle is above 50%.  There is a parameter in the motor calibration where you can set the minimum level at which the motors are power to when the throttle is a low.  There is another parameter to set the throttle level so the copter hovers when the throttle stick is centered.  You should check all of that as well. 

      Lastly, does your AMP produce Flash Data logs? Do you know how to download and display them?  That will be a vital step if you are going to get to the bottom of this.

      Unless you are on AC3.2 or higher, you will have to pop the flash card out of the APM to access the logs.

      I also suggest that you try to get radio telemetry running.  It gives you real time display of the copter and mission progress on a ground station computer.  You can monitor critical parameters while the copter is flying.

      I look forward to your next update.


      I think you are getting closer  to having a working copter. 

      Electronic Speed Controller (ESC) Calibration — Copter documentation
    • I'm starting to think that maybe I was the lucky person to recieve the most jacked-up APM they had in stock. I've gotten it to run for as long as I leave the throttle on now. But now I have another problem.

      When I do the ESC calibration, if I arm it immediately after it confirms that the ESCs have been calibrated, without first unplugging and re-plugging the battery. It acts as before where it only respond to throttle commands.

      If I unplug and re-plug the battery after confirmation of calibrated ESCs, then it responds to All other commands properly, except the throttle. For the throttle, it powers up the motors and slowly increases their output to about 20% and sits there, it still increases or decrease the motor based on the accelerometr positions or the yaw/pitch/roll inputs. But if the throttle is not down completely, with the motors off, then it's on and at about 20% it will not go any higher or lower unless it's going off.

    • Hmm, I thought I'd done that already, just a few hours ago really, but this time, it works. The mostors respond with whatever direction you tip the copter and the transmitter. However, now after about 5 seconds it stops and disarms, refusing to re-arm until the battery is dis/re-connected

    • I have a Power Return Module that connects to the receiver, but it only appears to be measuring the voltage of the main battery and the voltage being supplied to the receiver.

      The BEC can be connected directly to the APM (I'd use channel 7 on the inputs side of the APM, in this configuration) with auxiliary to power the receiver (from channel 8 on the inputs on the APM to channel 10 on the receiver).

      Or it can be connected to the receiver (on channel 10), with an auxiliary to power the APM (From channel 9 on the receiver to channel 8 on the APM) .

      In either case when the copter is connected to the main battery, the receiver shows that it is getting 5.0 to 5.1 volts, no matter which way it's connected. If the copter is connected only to a USB power source,  the receiver shows that it's getting 4.6 to 4.8 volts, unless it's then connect to the battery, at which point it goes back up to 5.0/5.1 volts.

  • Update: I've noticed that the only thing that gets the copter to act correctly is it's connection to my computer via USB. It doesn't matter whether Mission Planner is opened or not, as long as it's connected to the computer. This got me thinking, what it's simply responding to the extra bit of power that it get from the USB connection. So I tested this theory using my video game console, and it worked. It's not necessary that it be connected to my computer via USB to work properly, it just needs to be connected to /something/ via USB that's providing power. Which I think means that the Flight controller is , for some reason, not getting enough power from the UBEC.

  • Darius

    What happens when you connect to the copter with Mavlink and move the copter around in all three axis?  Does the Heads Up display track all your movements? 

    Sounds like the copter is at least arming correctly.  Do you have all of the Pre-arm checks enabled?  If your accelerometer is not working properly, it should show up there. 

    If you go to the Fail Safe page under Initial Setup, you can observe the motor outputs in response to the throttle after arming.  Put the copter in Altitude Hold mode, arm it, and raise the throttle up just a notch.  You should see all 6 motors run up the same amount.  I am curious what you see there. 

    Next, arm the copter in Stabilize mode.  Hold on to it firmly by one of the legs, better yet, remover the props first.  Then raise the throttle a notch and move the copter in any or all axis.  Do the motors try to respond or does it do nothing at all?  If it does nothing, then you have a serious disconnect between the IMU and the APM. 

    You can also examine the flash data log from any of these tests to see if the accelerometers and gyros are responding or reporting anything. 

    One last thing.  Did you have to change the direction of the pitch control, and if so, did you change it in your transmitter, or in the copter parameters?  When I first got my setup, the pitch was backward so I changed the RC2_Rev servo parameter to -1.  I had some funny behaviors in Super Simple Mode mode at first, but it may not have been related.  The prescribed method is to leave the servo parameters and normal (+1) and make any needed corrections on your transmitter. 

     Good Luck,


This reply was deleted.