Problem with Hexacopter using APM 2.8


I recently purchased a Tarot 690s hexacopter , it was partially assembled (e.i the ESCs and UBEC were already soldered to the PDB). The Flight controller is an Arducopter APM 2.8 and the TX/RX combo is The RadioLink AT10 and RadioLink R10D. The problem I have is, upon take-off the copter immediately tips over backwards and the rear props hit the ground. I've tried everything I can think of. Double checked the props and motor rotation, the signal inputs and outputs,  everything. Reinstalled the firmware for the APM. Updated the firmware for the transmitter. Still, nothing worked.One would think that you could just trim something like that out with the Transmitter, but I tried it. This led to the discovery that the copter isn't responding to any input other than the throttle. It doesn't respond to the yaw, pitch, or roll inputs from the transmitter. Nor does it react to its own internal gyros or potentiometers, when you tip or rotate it manually. Nothing but the throttle. In mission planner it shows the the transmitter is sending all of the signals to the apm, but it doesn't react to them. I don't know how to fix this at all.

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


  • The results from the previous post also holds up when I connect the copter via USB, to one of those little portable batteries used for recharging a cellphone, on the go.

    • Darius, Sounds like you are getting somewhere on this problem now. 

      Do you have a power module that is configured to measure voltage and current, and is it providing the main Vcc power to the AMP?  Or is the power only coming from a BEC connected to the servo rail?  Either way, can you generate a Flash Data log file?  If you can, then we can look at the internal Vcc voltage under the condition of USB power vs BEC only.  A Telemetry Log should give you the same data as well.  What are the specs on the BEC in terms of max current?  Is there anything else on your copter that is being powered by the BEC or just the AMP?


    • Here is a telemetry log from Mission Planner. I connected the copter, tilted it in every direction, the replaced it on the floor. Then I connected the battery, tilted it in every direction and placed it on the floor again. Then I armed it, throttled up the motors and tilted it in every direction  the replaced it on the floor, and with the motors still going I flipped all the switches to change flight modes, then I disarmed and disconnected it from MP.

      Also I forgot to mention before, the max current of the BEC is 5 amps

      2016-04-25 13-40-59.tlog
    • Was the USB plugged in for all of these tests?  It appeared to be from the Tel log.  My display showed the battery voltage to be in the 3 - 3.5 volt range and the idle current was up around 6 or 7 amps.  That is a mystery to me?  May be because my display is configured for a different FMU.  What battery are you running, and what is the nominal voltage?

      In any case, the internal APM supply voltage looked solid at 5+ volts. 

    • Yes it was connected via USB the entire time, that is the only way I could connect it to the computer for logging. Is there another way to create logs? The battery is a Turnigy 10000mah 4s discharging at 1C. Listed voltage is 14.4 I think. The voltage that the PRM shows is about 15.3 volts

    • The APM should create a Flash Data log.  Is there a micro SD card plugged into the APM?  You can find instruction on the Wiki how to load the data logs into Mission Planner and read them, or share the log file for others to look at.  Alternately, you should have the radio telemetry set up so the ground station can monitor the flight data in real time.

      I am still uncertain on how you are powering the APM.  Please look at these diagrams  and

      The prescribed method to power the APM is using a Power Module plugged into the PM port on the APM.  You can provide backup power through the servo rails, but that should not be the primary approach.  This might explain why things only work when plugged into the USB port.  The USB will also provide primary power to the APM. 

      Archived:APM2.x Wiring QuickStart — Copter documentation
    • This is my APM -

      an Arducopter, supposedly version 2.8. I'm pretty sure it's a knockoff. It is being poweredvia the servo input rails, the wires that you can see plugged into channel 8 are what provides it's power.

      The wires plugged into channel 8 are connected on the other end to channel 10 on this fellow-

      My R10D receiver, which is paired to my AT10 Transmitter.

      Also connected to the receiver is the UBEC-

      this would be the wires you see on channel 9.

      The UBEC is soldered directly to the Power board visible in the picture. It was the only means of power that came with the system.

    • Awesome!  I hope all goes well with your test flight.  I like to take off in Altitude hold mode.  It puts less pressure on the pilot to maintain altitude control AND fly the copter.   Once you get it flying and are confident about the stability in Altitude Hold mode, you will want to run an Auto Tune so the AMP can tune the RPY stability parameters.  Read up on it here:  

      After a successful autotune, it should fly very well.  I am anxious to hear how it goes.


      AutoTune — Copter documentation
    • It flew :3. I landed a bit hard and snapped both of my horizontal landing struts, also manage to tip to over and snap the gps stalk ( they should totally make those out of metal spring) but that totaled out to shorter sturdier struts and I rigged up a way to support the gps. I didn't realize it flew headless so I was having a bit of trouble controlling it at first.  But yea after a bit of trimming it flies great.

    • I can't reply to your last post so I'm replying to an earlier post.

      Check the parameter THR_MAX.  It' is set to 80 in the log file which translates to 8%.  A google search showed that others have had the same problem with AMP 3.2.1, the copter will power up, but not lift off.  It will try to respond to RPY inputs.  Set the THR_MAX parameter to 1000 and try again.

      Also the log file recorded a FAILSAFE_GPS error after arming.  According to the wiki, when the GPS Failsafe triggers, the copter will either land or go into altitude hold mode.  Not sure what that was all about. 

This reply was deleted.