Hi.I have a problem when I'm trying to do a Radio Calibration on my tricopter. Have connected my receiver and the APM, and when I give either roll or pitch input both the pitch and roll bar in Mission Planner move simultanious. It almost seems like pitch and roll are connected in some strange way.Have tried the outputs from the receiver with a servo just to check, and that works. Also no short between signal input pins on APM.Any ideas on what is causing this?Receiver is FrSky, and transmitter is Turnigy 9X with er9x.Firmware ArduCopter V2.9.1b Tri.Also please have a look at my video showing the behavior I am describing. [URL]https://www.youtube.com/watch?v=3jqd8S5djS8&feature=youtube_gdata_player[/URL]Have tried loading the V2.6 firmware without any different result, and also V2.9.1b quad.I must also add that if I connect [B]only[/B] roll (Ch1) or pitch (Ch2) to the APM I get response in both Roll and Pitch in the MissionPlanner.I also tried a complete different system, a 2.4 tx/rx I had lying around and the result is exactly the same as with my Turnigy/Frsky combo. Roll and pitch are acting strange. I feel its safe to say that tx/rx is not the problem, and I beleive the fault must be in the APM somehow.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Problem Solved!

    After I updated my receiver to handle PPM out and use PPM between the rx and apm, everything works fine. Finaly got to do my radio calibration without the roll and pitch going bananas :)

    Thank you for your contribution.

  • Probably you have mixage on those channels. Have you checked the radio is in plane/glider mode and NOT in helicopter mode ? Heli mode may have mixers pre defined.

  • Check that there isn't any mix active on your radio. If you can't figure it out, try making a new model on the radio. Just create a new model and redo this calibration test. The new model comes default with no mixing at all, hence it will rule out a mixing problem if this persists. 

This reply was deleted.