The throttle on my pixhawk 2.4.8 does not work

Hello, I recently had a problem with a pixhawk 2.4.8 board, and all channels work, except channel 3 of the throttle, I have already tried several things and even then it does not work, try to go back to a previous firmware version and I do not work either, I do not have anything connected to the pixhawk, only one servomotor and the receiver, when I place the servomotor in any other channel, this one responds to the movement of other levers from the radio control, but when I place it in channel 3 of the throttle , this does not move, it does not respond, even when I raise and lower the throttle lever on the radio, I have tried to connect the servo motor directly to channel 3 of the receiver and if it moves when I raise and lower the throttle lever, it seems that the problem is in the pixhawk, now I am using the latest version of ArduPlane 3.8.5, but it seems that my problem continues, when I go to the "Radio calibration" section, I see that if it detects the movement of the thottle when I move the lever of the radio, which is normal, but when I go to "servo output", and move the throttle lever, none of the bars moves, the bar of channel 3 remains static at 1100. Could someone help me?, I've been 3 months with this problem without giving any solution.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • It seems that your Tx is not config properly. There are mix on throttle or ch3 is not throttle.

    in pic 1 : is throttle full?

    in pic 2 : what is the position of throttle?

  • Hi Oscar,

    When you arm the AP with the safety switch it releases the servos. You have to arm the motor with the throttle/rudder stick pushed to the bottom right for a few seconds. Here is the link :

    Good luck

    Arming Plane — Plane documentation
  • I do not think it is necessary, since I do not have anything connected to the outputs of the pixhawk more than a servomotor to verify that the output is really working, as seen in image 1, in the calibration of the radio, if it detects the movement in the command in the throttle, but in image 2, it does not detect anything in channel 3.
  • Throttle needs to be calibrated. Look up Pixhawk ESC calibration.

  • Of course, obviously
  • Have you armed?

This reply was deleted.