APM pass thru

Newbie and still getting used to the format here so I posted this initially in the wrong category.  Here is my earlier post from "Aerial photography"...

Hello, new member, first post here.  Setting up APM1 on a boat - Traxxas Spartan.  Had loaded ArduRover 2.0 to APM through Arduino IDE.  I was playing with some configuration settings in Planner and trying to figure out the whole AUTO mode thing.  First strange behavior I encountered was throttle suddenly going on full, with no RC control.  Pulled the battery connection and troubleshot that a bit by removing APM - RC system worked fine.  Then when I reconnected APM I got no power at all when I connected the battery.  Seems to me the firmware may have been corrupted?  Tried rewriting ArduRover to APM and then ArduPlane from Planner but same result each time.

After reading through several posts I'm thinking it would be a good idea to erase the Eeprom.  Can someone let me know if that sounds reasonable and tell me what is the procedure for doing that?  I saw a post by Chris Anderson that mentioned the code line "CLI setup/erase", but I'm not sure where or how to enter that.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Moderator

    * No power - if your APM power LED does not light up, it is not a firmware issue. Troubleshoot as a hardware issue. Check to see if JP1 is present first. You might have toasted a diode on the board. You might have shorted the board out, or you might be connecting power or the RC unit incorrectly. See the next item before you do anything....

    * See the ArduPlane orArduCopter manual for instructions, even if you are setting up ArduRover. There is more information about setup, hardware and software, for those two projects than any other project. I recommend you read one of these manuals from start to finish before you continue to play with your APM.

    * For CLI information (in general) see here, here, and here, in that order. But go back to item #2, above, first.


This reply was deleted.