APMrover2 2.42 released

The rover development team is delighted to announce the release of APMrover2 2.42!

This release contains numerous small improvements that have accumulated over the last couple of months. Many of the improvements came out of the period of intensive development and testing that Tom and I put into the code before the ACV2013 competition (which we were delighted to win!)

The main improvements were:

  • fixed voltage calculation for RSSI receiver signal logging
  • use projected GPS position for waypoint calculations. This helps a lot for tight missions, such as around the barrels at AVC
  • disable cross-tracking over last 3 meters of each mission leg, to prevent fishtailing as a waypoint is approached
  • fixed change of speed command in missions (it was off by a factor of 100x, leading to some crazy speeds!)
  • fixed MAVLink logging of sonar distances
  • made it possible to change AHRS_ORIENTATION at runtime without a reboot
  • added new RCMAP_* parameters to allow for having RC input channels in any order
  • added new internal task scheduler for more accurate timing
  • fixed HIL simulation code
  • fixed handling of PX4 servo arming
  • changed the AUTO_TRIGGER_PIN to be push-on/push-off

Meanwhile Tom and I are working towards adding the L1 navigation controller for the next release. We didn't put that in this release as we aren't yet happy enough with the performance. We hope to get that fixed soon!

The other thing that has changed since the last release is that we have switched to the new documentation site. The docs have improved a lot, although there is still more to do!

Happy rovering!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • 3D Robotics

    If you haven't already seen this, you be interested in this demo of ArduRovers swarming in Leader-Follower mode, using only GPS. Worked great!

  • Hi,

    I am having a problem with the Learn Mode, when I hit the momentary switch it seems to load every Way Point into the APM that I have ever loaded; When I hit the switch the mission planner show over 17 way points instead of the one I hit the switch to load.

    Any thoughts on a solution.


  • Hi,

    I want to put a Sonic Sensor on my Rover. Which one to you recommend the 1240 or 1340?  


  • Hi,

    Does anyone have any advice on tunning the Steering PID and Cross Track values? I have the Rover working great now but I think it could be better.

  • The Rover is working much better now, thanks for the help.

    I changed the Crosstrack Entry Angle and the Crosstrack Gain, does anyone know what the default are and what these parameters do?


  • Hi,

    Everytime I switch to Auto mode the Rover backs up in a circle and sometimes stops or simply moves backward aimlessly. When I am in Auto mode if I move the throttle stick to forward the rover moves forward and the wheels steer back and forth and it moves forward aimlessly. What am I doing wrong?


  • Hi,

    I have my APM2.6 with telemetry set up on a Traxxas 1/16th brushless Revo. When I set way points and send them to the car just roams around aimlessly. Sometimes it goes backwards. Any thoughts on what I am doing wrong. I have calibrated the Compass.


  • Hi,

    Does anyone know the shipping date of the APM 2.6? This 2 day lag from customer support is curious.



  • Does anyone else sell the APM auto pilot?

    I ordered one from 3DR 2 days ago and got an email from them telling me they don't have it in stock. The took my money for the product and shipping and have not answered my emails asking when it will be in stock. It is my first order with 3DR and it maybe my last.



  • Hi, I´m just testing my new and first AR in 2.42 version. I´m using a Traxas Stampeed p/f with a APM 2.0. I now well Arduporter, so it wasn´t so difficult to get ready.

    All it´s running OK except I can´t tune the AUTO mode (see this video showing two WP´s test). I allways get theis anoying "snake effect". I moved up-down the  two main params driving that:

    XTRK_ANGLE_CD and XTRK_GAIN_SC. Also the speed I´ve reduced to 3m/s. But it looks nothing change in the behaviour.

    I used the MP from a PC (W7) and also with Droidplanner, but same result. Are params changed correctly for you using MP?

    Thanks for any help

    Angel (afernan)


This reply was deleted.