Help! No throttle or steering response!

Hi all.

I know this is an Adurover group, but Thought I would reach out and try my odds for some help as I'm perplexed by this problem. 

I have a Traxxas X-Maxx set up with a Pixhawk Cube 2.1 and the Here GPS. I'm using a Tarranis X7 remote controller and a X8R Sbus Receiver. I'm using QGroundControl with the latest, Pixhawk 1.8.0 Firmware with the Generic Rover airframe profile installed. As instructed, I have Steering servo wired into Main 2 and Throttle ESC wired into Main 4. Sensors are calibrated and green, flight modes are set to Manual and Mission.

Everything seems to be set up and testing fine except throttle and steering are not responding whatsoever when armed. I have tried everything I can think of, Tried the other rover airframe profiles for the Traxxas and Axiom Racer, still, no go. I did check to see if it was a rover mechanical issue and wired the steering and ESC servo cables directly to the receiver. It fired up and runs fine as a standard RC truck, so I know everything is in working condition.

I did test ardurover and it works fine but I really don't have the option of abandoning Pixhawk for Adupilot as this is a team project with members developing software for pixhawk rover firmware,

Anyone else having this problem? Any ideas that I should try? All feedback is greatly appreciated.

Big thanks in advance!!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Antonie, 

    Firstly I was using the PX4 flight stack and attempting to load the Rover profile through the Airframe tab in QGroundControl and was having no luck and later abandoned the PX4 firmware for ArduRover and now everything works pretty well.

    The one thing I could still use some advice on is the Reverse feature.

    Again, I have converted a Traxxas X-Maxx into a rover using the Pixhawk Cube 2 controller kit with a Here GNSS.I swapped out the original X-Maxx remote controller for an X6R receiver and Taranis QX7 radio. 

    The rover has an EZRun Max6 ESC. 

    The problem now is the ESC control over the transition into reverse. The ESC is currently set to it's Running Mode Option 2: "Forward/Reverse with Break", AKA the "Double Click Method".


    What this mode does, from Flight mode: Manual, is go from throttle stick Forward to pull full back for a breaking stop, then to center stick position, to Throttle stick pull back for reverse.

    Or Forward, Break, Stop, Reverse.

    Seems to be factory set as such for safety. 

    This behavior is thwarting our desired effect in Auto mode of Forward, Break, Reverse. 

    Is there a way to program this ESC to conform to this desired behavior? Has anyone else had this issue and what was the effective work around?  Is there an alternative ESC I should install instead?

    I hope my explanation is clear.  Big thanks in advance for your help, great minds of the Forum! 

  • HI El7ias

    This might seem like a stupid questions:

    1. Did you calibrate your radio(RC transmitter) in mission planner? AP must know where the PWM starts and ends.

    2. Is your signal cable from the AP to the ESC/speed controller on the right pin - did you not switch the signal and earth pin?

    3. Is the signal cable earthed?

    4. Did you arm the AP with the safety button?

    5. Is the AP not holding for a GPS lock or other sensor check?

    Good luck, I hope you get it going.

This reply was deleted.