How to Get Logs from APM 2.5

Okay, I got a run in yesterday and thought it did great! There's definitely more I can do to make it better. However, to do so, I need logs and for whatever reason, I didn't get logs of any of the runs I tried last night. I'm using an APM 2.8 from RTFQuads (yes, I know, it's a clone but all I could afford at the time) and used the Tower app to do everything in the field. I'll need to check the log bitmask but for whatever reason, it doesn't show my GPS position, speed, etc. I see the waypoints in Mission Planner when I do a log playback and where I started the vehicle up but that is it.

I'm running v2.5, downloaded the logs using the DataFlash Log tab, then hit Download DataFlash Log via Mavlink. This was done right after I finished the mission and drove it back over to me.

I know how to do all this just fine with a Pixhawk as I have had the Iris, Iris+, and built a TBS Disco with a Pixhawk (all genuine) and have done even more at work. I usually grab the SD card when possible. But this is the first time I've tried much of this using the older APM variant and I'm confused. It has also been a while since I have used the Rover code as it has changed quite a bit.

Any ideas?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • T3

    I should also add I'm using the 3DR Ublox Lea-6 V1.1 without compass, a 3DR V2 telemetry radio on the rover, the RTFQuads PM, and using a Bluetooth Bridge on the ground side to go to either my Nexus 6 or MP on my laptop.

    • Admin


      I would recommend not downloading the dataflash logs over the telemetry as it takes forever for a large dataflash log (most of mine are 32MB or greater) compared to the usb link.

      There is no difference between downloading and analyzing APM dataflash logs or Pixhawk logs.

      The dataflash and tlogs are stored in the MP log folder and tlog playback or the dataflash log review or auto analysis can be directed to the appropriate vehicle folder in the log folder.



    • T3

      Okay, I guess I should have said I connected the APM to my laptop via USB and then using MP, the only way I could find that grab the files was to go to the DataFlash Logs tab and then grab it via Mavlink. Is there another way for the APM 2.X series?

      I didn't have any of the files on the computer since my BT Bridge was connected to my phone. I looked in the directory on my Nexus 6 where the logs should be but there weren't any files there so I couldn't grab any of those either.

This reply was deleted.