ISU Winebot

Hi everyone, I need some help. I am a grad student at ISU and we were challenged to make a robot to drive around a vineyard. knowing the ardurover software existed I did not think it was going to be that challenging of a project. Well I spend a few hours today trying to get a 4 wheel drive rc car (not sure the model cause when I got it, it was missing alot) to navigate to way points. This is the test platform before we move to the big robot. I am not new to the software, we have a few arducopters so I can get my way around the mission planner. I was able to set, and clear way-points using the RC remote, however when I would put it in auto mode it would start driving off almost in whatever direction the RC car wanted to go, it did not go in only a straight line but rather turned almost at random. The other problem we were having is the compass can not decided which way is forward. Sometimes it would know which way was forward on the car other times it would be completly off. We are using apm 2.5 bought just for this project. If there was a pattern I would have an idea where to start, but it seems so random that I am completely lost. We did have the telemetry connected so I know it had a 3d lock for gps and the HUD was updating. Any thoughts or comments would be extremely appreciated. Please let me know if there are any questions I can answer that will help

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi all, thanks for the help. Today I updated the firmware to 2.41 moved the autopilot 7 inches away from the motors, and the rover behaved really well today after I calibrated the compass. It all worked well until the motor control stopped working, got to figure out that problem next. Thanks for the help,

  • Here are the details of the test platform

    APM - 2.5

    Power supply - 5v from motor controler

    Motor controller - Traxxas 3014

    GPS - 3DR MTK v2.0

    Firmware - Should be 2.4 (not sure how to tell, but i installed it last week)

    Telemetry - 3DR

    RC system - Specktrum dx6i\

    Drive system - 2 motor geared to single drive axel. 4 wheel drive

    The steering is a good thought, completely missed that. I also did think that the magnetic fields might be messing with it so I tried disabling the compass which didnt help. I will move the autopilot further away from the motors on monday. Thanks for the quick reply's guys

  • Admin

    Hi Greg,

    To help the ArduRover User Group members assist you in troubleshooting an issue it is always a good idea to give some basic information concening your navigation system:

    Type of processor being used

    Type of APM power supply

    Model of GPS

    Firmware version

    Other accessories and where they are mounted

    Proximity of compass to magnetic fields


    Since you are using an APM2.5 it would be best to purchase an external compass, attach it on a non-metallic pedestal above the chassis and follow these wiki instructions: Did you follow the wiki instructions to calibrate the compass? I have my compass on an aluminum pedestal mounted about 5 in above the chassis and just behind the centerline of the front wheels. Is your rover a rear wheel drive?

    Have you verified that the APM is steering the rover in the right direction when in auto? I have a Slash rover controlled by an APM2.5 and it turns out that the steering control in manual is the same as in auto. However I have an E-Maxx and the the steering control in auto is opposite that of the manual mode. You can change the steering direction in auto by clicking the "reverse" box in the MP radio calibration page. I use a servo tester to read the output of the APM steering in in the auto mode to ensure that the APM is steering in the right direction to the first waypoint. If it isn't then you need to reverse the auto mode steering direction.

    Hope this helps.



This reply was deleted.