Mission (not) Reset


I posted the following on the Tower (DroidPlanner) Git issue forum, and received a reply that this may be an ArduRover issue, rather than an OCU software issue.  Interestingly, when I use MissionPlanner I don't seem to have the same problems - but I haven't thoroughly tested for it.  MissionPlanner has the handy mission reset feature, which I use, and may be the reason why I'm not seeing it there.

Driving around last night, I aborted a mission by hitting hold and then RTL. I edited a new mission, and uploaded the waypoints. When I switched to Auto for the 'new' mission, the AP tried to go back to the 'old' mission's last achieved waypoint.

I cleared the mission in Tower, and uploaded no waypoints to try to clear it out. Then, created yet another new mission and uploaded it. Switch to Auto, and it still headed to the original 'old' mission's last achieved waypoint.

I let the asset drive it out to the end. Created and uploaded yet another 'new' mission, went to Auto, same thing. Only a reset of the PixHawk would clear it out and let me conduct a new mission.

Is this a Tower or ArduRover firmware bug? I'm glad I'm figuring this out with a rover, in a large parking lot with no obstacles...


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I believe it's likely in the rover code. I've had issues where I cannot reset waypoints with my transmitter, no gcs.
    The first attempt to clear previous WPs after reboot often works, but after that, no luck.
    • I had the same issue, then followed Thomas' advice and set the MIS_RESTART parameter to 1.  Once you do that, you should be able to reset the waypoints with your RC Tx by toggle the set waypoint channel while in Manual mode.

      I haven't tried it yet personally, but setting this parameter helped with my Tower issues...

      Let us know.

  • Admin


    What do you have the MIS_RESTART parameter set to?



    • Well, thank you for that.  I didn't know that parameter was available.  I do have it set to (0), resuming the mission after Auto mode selection.

      This is a mixed blessing, as we really need both behaviors.  Pausing for traffic (Hold) and then (Auto) to resume is a great feature, so I really don't want to change the parameter to (1). 

      I guess this really boils down to Tower not having a mission reset feature after all...

This reply was deleted.