Traxxas Slash Manual Mode is not moving forward at all

Hello everyone,

I am using a Traxxas Slash vehicle using APM 2.5,external compass, and Turnigy 9X radio-- as the one I am showing in the link: ... GpYWC02Nlk

I followed the setup from the wiki. However, the car does not move forward just the steering on Manual mode. . I had been going over the forum and found out I have to do an ESC calibration like in a quadcopter. If so, is the process the same? I had searched about it and had only come across ESCs calibration for UAVs.

Also, I am using Turnigy 9x Radio and receiver. On Mission Planner doing the Mode Setup, I am only able to get one mode and not the others as described in the wiki. Do I have to do the setup for modes on the Radio? If so, is the process the same as for a quadcopter.

Thanks for any help provided.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Admin


    Good advice that will probably resolve his issue.

    However it looks like Virgil has his ESC connector plugged into servo output number two and if I remember correctly when I used the APM2.x navigation controller I had the ESC channel plugged into servo output channel number three when I was using a normal R/C receiver on the APM R/C inputs. This assumes that the Roll and Elevator joysticks are used for steering and throttle respectively.


    I notice that you have an open chassis in your picture. In my experience with two brushless 4WD Slash Rovers, it is best to have the navigation controller in a case or covered in some way to prevent dust, dirt and water from causing electrical shorts.

    Also, rovers are prone to flipping over at unexpected times and having the GPS/Compass module on a pedestal is just asking for trouble. I suggest that you mount the GPS/Compass module up forward in front of the front shock towers.

    3691128551?profile=originalAbove is a top view of how I laid out my navigation controller and associated components on my 4WD Slash Rover to keep the GPS/Compass module as far from the brushless motor as possible. Also the body mounts on the spring towers protect all of the onboard components incase of a roll over.

    I have a highly water resistant version that has a transparent cover/shield over the Pixhawk and a clear Lexan body that covers the entire chassis.



    • Thanks for the advice.

      I have the Traxxas Slash running in Manual mode. But I am having another issue. I have set the mode as described in the link: Auto, Auto, Learning, Learning, Manual and Manual. As I am driving the rover in Learning mode and flick CH7 (which I set as waypoint on the parameters) toggle to record a waypoint, I see in the HUD of MP that it switches to learning. I am not sure if this is correct because I am not able to delete previous waypoints. For some reasons, the newer waypoints are being added to the older waypoints, and the rover takes off in reverse. To delete waypoints, I did what I found in the different links such as driving in Learning mode and toggled CH7 to clear the waypoints list. But it is not clearing the list. I also tried to delete each point manually, and then I tried to read in MP the new mission and got to see again the newer plus the older waypoints all added together.

      Thanks again for any other advice provided about this issue.


    • T3

      I believe one of the devs mentioned in the T3 challenge that there are some existing issues in the Rover code and this is one of them unfortunately. It may have been something similar but there were some mission related items that I had issues with as well that are similar to what you are experiencing.

    • Thanks for the response.

      Yes, I had been checking out the forum, and it is a problem. The learning mode is not working for me. As I toggled the switch to channel 7, waypoints are recorded but to the already waypoint in the APM. To delete, I set up waypoint to run in the auto mode, and that is how I am able to delete older waypoints and start a new mission. But in the auto mode, the vehicle goes in reverse. According to the forum, I had tried to check the reverse on APM when setting the radio calibration. Also, I have tried to control the speed, but the vehicle still takes off fast in reverse. Any idea how to solve this issue you may provide me, I appreciate it.  I had to reduce the numbers in the parameter lists to control the speed, but again I had come out empty.


  • T3

    You need to calibrate your Traxxas ESC to the 9x you are using. You can find the instruction manual for the ESC online and it will show you how to do it. I recommend calibrating it and using the right stick that's normally used for the elevator for it.

This reply was deleted.