Iris+ with Google Nexus 7 tablet.

Went out for my 3rd flight today, and could not get DP2 to connect.  Constantly got MAVlink error: No devices found. It worked fine yesterday.  I was using Mission Planner yesterday to extend the geo-fence to 1000m.  I also changed the 3DR radio telemetry settings, but only changed Airspeed to 32.  I have since "reset to defaults" but it still won't connect.

Had a flip, as the copter was landing (windy South Dakota), and I decided to open up the shell in order to clean a little dirt out.  The Fr Sky telemetry module cable (red, white & black) was/is hanging lose.  I assume that it must be plugged into the PX4 module.  Must it plug into the RC slot? Black cable up?

Could this be my problem?

Any suggestions for setting up the 3DR telemetry?  I was trying to get more range out of the tablet. :(

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I FINALLY figured it out, after coming across a random post here. 

    1.  Always make sure that the blue end of the USB is plugged into the Android device. 
    2.  Your tablet/phone needs to be in DEVELOPER mode.  Open Settings > About Device > tap Build Number like crazy> You will be told you are 3, 2, 1 taps away from developer mode.  Restart Android device.  \

    3.  You may need to open the Iris+ shell to access the inner radio.  I could not do this through plugging the PX4 into mission planner,  as tech support said I could.
    4.  You MUST unplug the cable from the PX4 to the radio (under Iris+ shell), in order to update radio settings.

  • Global,
    Have you got the correct end of the telemetry radio cable connected to the tablet? The cable is NOT bidirectional. The blue end MUST be connected to the tablet.
    • Yup! I FINALLY have it figured out.  Will post below.

  • Hi Global,

    DP2 is way out of date at this point.. I suggest you use dp3/Tower app instead..(depending on your version of android)

    you will also need to download the 3DR services API app

    versions of android earlier that 5.01 seem to have lots of USB arbitration/power issues ie powering down the port even though a device just plugged in etc.. also try plugging and repluggin and power cycling that eventually got a response out of my samsung tablet before upgrading...

    may want to down load the PHILZ touch updater for your device and get on 5.01( bricked tablet warning here be careful)

          good luck


    • Thanks! I've already got Tower, but that doesn't connect either. :/  Connection Failed:  No Devices Found

      Is it possible that I changed the telemetry radio settings incorrectly?  If I change them on the external, do I need to change them on the internal as well? Does the control, and Iris have to be on?

      I'm not really prepared to risk a bricked tablet. 

    • no the problems you are having clearly relate to USB issues in Android below 5.01..  and Tower HAS to have the 3DR services API loaded...

      your problem is not telemetry radio setup yet.. you cant even see the HW yet..

                the PHILZ touch recovery went VERY smoothly to 5.01 on my old samsung tab 2 7" just back up all data needed beforehand..(I was up against the wall with no/bad connectivity anymore till I upgraded

      this stuff(tower and 3dt services API)  wont work very well  till the USB connectivity issue fixed first

      code doesnt seem to work very well below 5.01...

            good luck


      btw I wound up loading up ADT and the sources and registering for a google MAPS api key for the code I compile myself.. that way I dont have to wait for the next release, the USB was a very frustrating issue but its Android versions and their USB support for same that are your problem here not tower or the services API..(this assumes you ARE using an OTG USB connector(supplied)..)

  • OK, I am now confident that I am plugging the Fr Sky module into the PX4 correctly.  It now gives a green LED light.

    Still not able to connect via DP2.  Would this be because of my fiddling in MP?

This reply was deleted.