After crash Iris do not spin motors succefully armed

So, that's the story.

As always i used my Iris, but suddenly it lost transmitter signal and crashed into the building, right in the window and fall down from third floor. Broke blue arm, and that's all, even props are ok.
File comment: broken leg
1.JPG [ 274.92 KiB | Viewed 1 time ] 

To check if systems are alive i turned it on and it lighted with familiar sound. So i was sure that it's alright. I don't remember was the backdoor light flashing or not.

I disassembled it carefully, repaired the arm, re-assembled and tryied. So, first of all i noticed that the light on the backdoor doesn't flash. I thought that maybe it is a loose wire, but every connectors were on right places.
File comment: cured arm
2.JPG [ 341.04 KiB | Viewed 1 time ] 

The problem i didn't solved.
further i checked the colors flashed through the bars in the upper shell on pixhawk.
So, transmitters swiched on, battery plugged in, i see the telemetry , GPS locked (9-11 satellites), altitude hold, motors armed (i noticed that props twitched as always). and.....nothing... the light on pixhawk just impulsed yellow color. I try to start motor but only hear a bad tone from iris. I waited for 5 minutes, everything switched off and on again and again but useless.

I don't know much about it, and don't know what it can be the issue. Does anybody could help me?
I understand that i need to read logs but i don't know how couse i don't have antenna for ground station. I took the microSD out of and copied on my pc, but don't know how to read it.

Maybe someone already gone through that issue or could give a good advice?

Thank you in advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • So, i just solved the gimbal's jitters problem. Also

    Update of gimbal firware in windows 10 IS POSSIBLE.

    Thanks to these links:

    1) win 10 drivers for Tarot gimbal manual:

    2) gimbal jitters problem fixing:

    Thank you guys!

  • Well, what i have to say now after the week of exploring Iris issue.

    I spent for 2 evenings reading and watching the different information about the Iris, specifications, modes and etc.
    I took off The IRIS again, thanks god i repaired it.
    3drobotics didn't answer, didn't send any mail back. that's sucks.
    I was needed for any help to put me in right direction.

    Thank you very much DAVIDFOLTS. You put me in right direction, except for: 3dr teem didn't answer, and during the uploading the mission the error happends, so i could upload it.
    So, re-installed the firmware, recalibrated every item on board. And shut up, it spins motors and stable in the right mode.

    But there are some issues that i still didn't solve.

    1. External led repeater still didn't flash. I changed wires and connectors to check, but useless. Meanwhile the arm-light is flashing well. I have read that i could be a)I2C fault. b)pixhawk pins voltage issue. I don't have time to examine that. So i ordered a new I2C. will see when i got it.

    2. Gimbal is not stable, it shacks like idiot. I tried to calibrate it, but did not enough i think. By the way i was unlucky in upgrading the firmware 1.5, because of the lack of drivers for windows 10. And i don't know what do to, so lazy to install win 7 or xp just for that. Maybe the issue in firmware, but maybe not.
    If somebody could help, would be great.

    So that's all for now. will keep you informed guys.

  • Put the SD card back, upload the mission you flew to Drone Share and go to the 3DR website and open a trouble ticket with tech support...they will take care of you. I been happens
This reply was deleted.