Compass Calibration - Some Real Basic Questions


I have an upgraded Iris to Iris+ and have been successfully flying for a few weeks now.  I updated MP to 1.3.24 and have AC V3.2.1 installed.  I have seen reference in this forum that when calibrating the compass a solid sphere should be created with points.  When calibrating the compass in MP, I select "Compass".  If I select "Pixhawk/PX4"  I can create relatively solid spheres but always receive  an "Unexpected error" message.  If I select "Manual" I never have enough time to create anything close to a solid sphere.  What am I doing wrong?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi guys, I`ve been having issues after a crash with my IRIS+, not a bad crash, broke an arm when I cought in on the air (propellers weren´t spining!). I seem to be unable to calibrate correctly the compass, I hope it´s not a hardware issue. I had to go back to MP 1.3.10

    I check "Manual", and select "ROTATION_NONE". Also "Enable" and "Auto Dec Detect". My best offset is -84 -7 -29 and on compass 2 I get -231 289 119. Is that good enough? On the "LogAnalyzer" everything looks fine expect "Test: Compass = WARN - Moderate change in mag_field (27.79%)". 

    Thanks for the help!

  • I have an unfounded belief that you should start calibration with the Iris+ pointed toward magnetic north.  My basis for that is a video I vaguely recall watching when first researching compass calibration on the Iris.  It works well for me, but its probably unnecessary.

  • You need to select Manual because there are two compasses and you need to get both of them calibrated in 3.2.

    The problem is that the auto complete does not work correctly so you will need to uncheck the auto complete and do your thing.  When you have both spheres filled in then click done.


    • If the offset for compass2 were unset (0) how would that impact flight? 

      I am trying to understand how 3.2 uses both compasses. At the same time? Chooses one over the other with some algorithm? Uses the external unless it becomes disconnected?


    • Michael, thanks for the reply.  But how do I "uncheck auto complete"?  The only options that are already checked are "Enable" and "Auto Dec".  I unchecked "Auto Dec" and still do not have enough time to complete the spheres.  How do I turn off auto complete? 

    • Duh....I found it.  It is on the "Progress" screen right after you hit "Live Calibration".  Problem solved.

This reply was deleted.