Gimbal Fail on Iris


So my Problem is that the roll servo often stops working and you have to push it a little bit that he works again. i think the servo is broken. but it was new from 3dr with my iris. filt works perfekt out of the box. but even with disconnectet red cable to pixhawk it make the same. Try different settings but always stop working on the same positions. i think a coil was broken?

Here a video from it:

Can anybody help me?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • My first Tarot gimbal - purchased with my IRIS - never worked properly... specifically the tilt never tilted at all (although it did roll fine) and channel 6 never worked. I spent a week my own trying to get it to work using these forums (watching all the vids and doing all the upgrades), to no avail. And then i spent a week with tech support going through all of their corrective measures, to no avail.

    Thank goodness 3D finally replaced my defective gimbal with another new one, and now it works like it should. 

This reply was deleted.