Iris+ no RTL, or follow me mode working.

So yeterday I went out and performed a mission using droid planner. went well, a few minor adjustments and everything will work great. However I also tried to flip my RTL switch on my IRIS+ tx, iris never responded at all. The reason I beleive it didnt work was because I think I changed a setting inside the TX when tring to get the tx paired up with trinity head tracker from FAT SHARK.

I am curious if someone can please help make sure all my settings are correct for the tx from 3dr.

Also after i performed the mission, I tried the follow me feature.

No luck, I followed the 3dr youtube video on how to make it function pressed all the correct buttons including having it in loiter mode.  When i pressed the pause button it yawed 180 and when I pressed the follow me function via droid planner. it flipped back, It would not yaw, or follow the device. The only settings the iris did respond to when using the droid planner with follow me was the land function and altitude change function. 

any suggestions? or help would be greatly appreciated. Also curios if anyone has attached there FPV cam to the go pro while mounted on a tarot 2d gimbal, for framing of shots, or perhaps help on which VTX is used by 3dr to get FPV from go pro which would be ideal....

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • ok, finally got rtl and follow me working.
    This may sound obvious to some. For whatever reason I assumed when i connected to droid tower and it confirms audibly. That the iris sees the droid device and follow me should work, loiter etc.
    I rarely have my gps on my phone being used. At least the gps I can control.
    Was told to turn it on my device.... And what do you know it does exactly what its supposed to and followed me!!!!
  • I don't think the arrows are a big deal only that the right stick chance the right arrow.

    Ch1 = Pitch

    Ch2 = Roll

    Ch3 = Throttle

    Ch4 = Yaw

    Ch5 = Mode switches

    Extra channels is not a issue.  Your transmitter only supports 8 channels.

    On my transmitter the arrows are dashes when centered and change direction when I move them around.

    I have the original IRIS transmitter.

    The CS1 for the second entry is a typo  so it should be CS2.

    This is how they make two switches look like one 6 position switch.


    • You know, I figured that second entry was a typo when I re-did my transmitter. Where's Colin when you need him? ha ha

    • I checked out that video by Erik yesterday and loved it.  Tree's and wires for me are still freaking me out a bit after a branch seemed to reach out & grab Hal 1 (I named them).  Not to get off topic, but did I just see a picture from that video on a billboard in Berkeley??  

    • Thanks but no that's not a still from my video on a billboard. That video was basically just a compilation of shots I took while learning the Iris. Now I've got a whole lot more footage and I'll probably re-edit with more family video of the kids and it will end up being a family video to remember the 2015 winter.
    • I found it online, it was an iPhone ad & from a glance it looked very similar.  I suppose one day we'll be able to suction cup a prop to an iPhone huh?  Sorry for the interruption - the video really was great.  

  •  so on page 15 of the user manual it says:

    Note: The arrows on the 4th column indicates the position of the sticks, switches and knobs. To have the same directions as the screen displayed, move the throttle down, the switches away from you and the tilt knob rotated counterclockwise

    Which looks like this:

    LIMITS 6/10

    CH1 0.0 − 100 ← 100 − − −

    CH2 0.0 − 100 → 100  INV

    INV CH3 0.0 − 100 ← 100 − − −

    CH4 0.0 − 100 − 100 − − −

    CH5 0.0 − 100 ← 100 − − −

    CH6 0.0 − 100 → 100 INV

    CH7 0.0 − 100 ← 100 −

     however mine wont allow me to change the arrows, however when i pressed the rollstick i would watch the arrow point on channel 2 just in the wrong direction regardless of which way i moved the stick.

    Any ideas on how to change the arrows. Ive followed the note: all switches away and knobs turned counter clockwise.

    Did I not do do the settings correctly?

    • Does it matter that channel 8,9,10 are apparently being used, Ive tried to delete the channel 8,9, 10, parameters. Nothing, followed the directions on page 14

    • Also noticing page 15 custom switches screen i has cs1 for the first entry and cs1 again for the next entry, However I just can't change that ccs2 to a cs1

  • Regarding follow-me:

    Sometimes you have to move pretty far before it kicks in when you first start follow-me.  I set my leash to 20 meters, and sometimes it doesn't really kick in until I've traveled 30 meters.  Once it gets going though, it tracks pretty darn well.  And of course you need to make sure that your phone is actually getting a good GPS signal.  You mentioned Droid Planner, but the the newest version is now called Tower (its basically Droid Planner 3).

    Regarding FPV:

    Yes I have attached the FPV, as have many people here.  Its very useful for filming.  I'd say its kind of required.  The only thing is that if you are shooting in 4K, your forced to use Wide field of view on a GoPro.  The combination of 4K and Wide gives you a lot of wiggle room to reframe in post using Final Cut or Premiere.  Especially if you are going to deliver in 1080p AND if you letterbox (which always looks better).  I can show you an example if you are interested.

This reply was deleted.