Iris+ no RTL, or follow me mode working.

So yeterday I went out and performed a mission using droid planner. went well, a few minor adjustments and everything will work great. However I also tried to flip my RTL switch on my IRIS+ tx, iris never responded at all. The reason I beleive it didnt work was because I think I changed a setting inside the TX when tring to get the tx paired up with trinity head tracker from FAT SHARK.

I am curious if someone can please help make sure all my settings are correct for the tx from 3dr.

Also after i performed the mission, I tried the follow me feature.

No luck, I followed the 3dr youtube video on how to make it function pressed all the correct buttons including having it in loiter mode.  When i pressed the pause button it yawed 180 and when I pressed the follow me function via droid planner. it flipped back, It would not yaw, or follow the device. The only settings the iris did respond to when using the droid planner with follow me was the land function and altitude change function. 

any suggestions? or help would be greatly appreciated. Also curios if anyone has attached there FPV cam to the go pro while mounted on a tarot 2d gimbal, for framing of shots, or perhaps help on which VTX is used by 3dr to get FPV from go pro which would be ideal....

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Is there a pot in droid planner or on my phone that will tell me about my current HDOP?

    • Enable it in settings. Upgrade to Tower. Droid Planner is the old software.
    • So ive been trying all day to reset the controller.based on the steps indicated , I must have an issue with my tx. I cant delete any of the parameters I can only go back and start a new model as indicated in the steps process. And when it comes to adding a line instead of going on to the next channel the buttons i press according to the steps just exits me out of the menu!!!!!

    • Going through the procedures and I cant find a way to continue the settings for channel 5. it puts me straight to channel 6.

      CH5 MAX -70 CS1

      := MAX -35 CS2

      := MAX -15 CS3

      := MAX 15 CS4

      := MAX 35 CS5

      := MAX 70 CS6

      CH6 P3 100

      CH7 MAX 100 

      Mine misses all channel 5 settings and goes straight to channel 6...

    • Thank you

This reply was deleted.