Iris + Problem reloading firmware

I've tried for weeks, but didn't find a solution.

A few months ago my Iris+ crashed without warning, 3DR sent me a new Pixhawk and with some other small bits I have everything back together again.

The only issue is, I don't have the original firmware, and APM 2.0 for mac does not allow me to load it. It just doesn't show up in the dropdown list. I can load a normal quad firmware file fine, but would rather have the Iris+ specific file as currently I don't have telemetry or follow me funtion with this firmware version. (I've tried the serial_2 setting, that didn't help either.)

So I have a way to load the file, but I don't have the actual file itself. 3DR cannot help me with this, they claim they don't have the file.

Is there a friendly Iris + user who can get me the file? Or is there a workaround? I don't have acces to any Windows PC's, I'm Mac only.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer
    Iris was runny the AeduCopter builds, There is a parameter file you can install. The Current stable,build is AC3.3.3 which you can easy load from APM Planner 2.0 install fw view.

    The parameters can be loaded from frame config view.

    • I can flash Arducopter 3.3.3 to pixhawk without a problem, I've done this a few time already. But I cannot load the parameter file, there isn't one to select from the list.

      Nothing happens when I press refresh or download in this screen, I know the Iris+ parameters are supposed to be in there. I could load them from the "Full parameter list " screen, if only I had the file. I see you can also save the file there, so another Iris+ owner could do this and I would be set.

      Thanks for the reply.

      Schermafbeelding 2016-07-06 om 11.04.43.png

      Schermafbeelding 2016-07-06 om 11.10.05.png

This reply was deleted.