Iris telemetry troubles

I recently bought an Irirs+ and have only had the chance to make a few flights so far due to weather and work. After those flights with just the copter I thought I would try it with the gimbal attached to see how differently it handles. After attaching the gimbal I noticed that I had no control of it via the TX, so I decided to check the webs and get an idea of what was going on..... I stumbled on a video that showed how to hook up via Mission planner and calibrate the radio.....that did not go well.....

After it installed the latest firmware I lost my compass calibration ( which took F O R E V E R!!!!!!) to get re-aligned! Fast forward to the latest issue which is now I can't hook up to my telemetry via the radio (dongle???)  that attaches to either my tablet or laptop. When I try the tablet (samsung galaxy note 10.1) it fails to connect and says low signal quality. When I try to hook up to the laptop (HP Envy Windows 8.1) it identifies it as " FT231X USB UART" but will not show up on mission planner as a connection to the copter. So I'm stymied at this point as to wether the dongle is screwed up or the copter is. 


It reads telemetry through the TX just not the receiver dongle. It worked just fine before I updated the firmware, so I'm not sure at this point what to do to undo what I did. I was hoping fro some guidance from the kind folk here before I submitted a trouble ticket to 3DR.

Thanks for any and all help directed my way!!!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had the same issues with my PC, I simply uninstalled everything and reinstalled.  After it reinstalled I plugged in the Telemetry Radio before I opened Mission Planner, I let windows do it's thing and once it was finished I opened Mission Planner and was good to go.  Check you baud rate as well.  If all else fails (3DR takes forever to respond) try a different USB cable to connect it to your computer/tablet.  

    Good luck! 

    • Actually have already had a response from 3DR, went through the step they suggested and have the tablet end of the radio link going, and it seems the problem is the internal radio end of the pairing. tried hooking up through the USB plug on the side of the iris but it wont recognize the radio...just a solid red light.

      Waiting to hear from 3DR about my response to them, maybe have to replace it? the internal radio doesn't have a USB connection on it so I have no way to connect directly , any other suggestions? 

    • Well got the radio issue fixed after another suggestion from 3DR, now I cant get her to stop going into alarm even though it's perfectly still when I plug the battery in and it has a clear view of the sky.....I get from 3 to 8 green flashes like it has gps lock when it goes into alarm (loudly!) which the only way I can silence it is by trying to arm the motors.My TX has said from 8 to 11 satellites when it goes into alarm. It just sits there single flashing the yellow light and nothing else......I'm truly starting to think I'm in over my head here....

      I'm not blaming the Iris just my copter problem solving skills (or lack there of)
    • Dont give up man. Once you get up and flying you will love it. Just be patient. Just make sure the accelerometer and compass is calibrated. PM me and I can give you my phone number and talk you thru the calibration process. I have done this with a few new iris pilots!

    • Here's a link to a youtube vid of whats happening:

    • I T L I V E S !!!!!!!!!!!!!!!!!!!!!!!

      After the emails from Armando at 3DR I re-formatted it, returned it to factory defaults and re calibrated the lives again and crack of dawn tomorrow I will be taking her into the air once more!!!!

      Gregg thank you for the offer and I may be taking you up on the kind offer if I screw this up again! 

      Thanks to all the community for the advice as well!

    • did you ever calibrate the compass? 

  • I was being stupid and realized the short usb cable attached to my telemetry module was pugged in wrong. Could not get any info to my google nexus tablet until I switched ends.

    • No my laptop doesn't have a micro USB slot so I used another couple of USB Micro to regular USB cables that I know work with no love. I finally put in a trouble ticket with 3DR which is based in the same city I live in, so heres hoping there is a simple and or cheap fix for me.....

  • Hi Joe, 

    With all the hours spent on my Iris+, I think I have encountered nearly every issue you could experience. Let me tell you what caused the most amount of hair loss when various things stopped working or failed to cooperate the way they were supposed to. After countless google searches and forum visits, I performed my own tests. I have about 6 computers at my disposal, as well as half a dozen VMs (Virtual Machines), and half a dozen Operating Systems. Incompatibility was the main cause of several unexplained problems. 

    The very first thing I would suggest you to do is check your baud rate. Both your baud rate set in Mission Planner and the com port your telemetry is using need to be identical (set in device manager). If they are the same, try using a computer with Windows 7. Let me know if this works or not. I'm happy to help you out further if you are still having problems.

This reply was deleted.