Some issues with Mission Planner and Drivers

Hello,  I have been getting acquainted with the installation process for the mission planner and the procedure for upgrading the firmware on the FCB (Pixhawk).  I have an IRIS+

First, I notice that the Mission Planner loads "digitally unsigned" drivers, This does not bear well for Win 8 installations as the user does not get the option to load the drivers anyway.  Secondly, if the user happens to encounter a break in transmission during the firmware upgrade, the mission planner will maintain an error situation thereafter and will not clear the event. This results in the user not being able to complete the upgrade of the firmware.  This error persists resulting in a situation the the user is unable to resolve.

 I am speaking here for all those users who may not be highly computer literate and cannot figure for themselves what is going on.  I have watched the videos and read the instructions available - and while these are extensive, they should not be expected to cover all possible scenarios (and evidently they don't)... but the software should be able to provide the primary support base by trapping and resolving errors effectively. 

It is not my intent to vent frustrations, and maybe I am talking to the wrong group here so I hope that my comments get to the right ears, because if this product is to measure up to the commercial realities then I think my comments will not be construed as inflammatory or derisive.  I really just want to help.

I have downloaded the latest Mission Planner along with the driver package so there are no issues with currency (I think).

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi all, thanks for your support.  I am both encouraged and humbled by your responses.  Thought I would provide a quick update as to my activities since it's Easter and I have taken the family away to a remote location 350Km from our home.  I thought this would also provide me with the perfect setting to retry the GPS lock approach and see what happens.  This I intend to do over the next day. Right now I am leaning towards Micahel's view of the situation, but one more test is not a burden for me.  I hope to post results in the next 24hrs.

  • here it is

    • Developer

      now because I have to ask..... is there actualy a problem Ronald? that logs shows the driver are installed on they system, just needs a device to be plugged in.

    • when I run driver installation it says it is installed but it is not there.  and is only there if I disable driver signing

    • I think it does have something to do with these telemetry radios.  even when mp is running i get a

      bubble saying that windows does not recognize the latest usb device.  when I use a direct usb

      connection everything works fine including upgrading firmware.

    • Developer

      that sounds like an issue the the device.

    • I suspect this too Michael.  But I will run some more tests.

  • I feel the unsigned driver issue will not play well for non WIndows savvy users who, naturally enough, do not know (nor should they have to know) how to perform an advanced startup and disable the driver check.

    Totally agree.  I have enough machines laying around with Windows 7 installed that I can't be bothered to install MP on 8.1, but it is annoying.  Tried once, ran into the unsigned driver issue and didn't even bother to reboot into advanced startup. Just grabbed a Win 7 laptop and used that.

    • there's a x64 and x86 .exe

    • x64 is the only one that will run and it says unknown publisher when you run it and drivers do not install

This reply was deleted.