Trouble With Auto Mode

Hi guys, so I am having some difficulty with auto mode with my iris. When I try to add a ROI waypoint to a mission it doesn't work when I go to fly that mission. It will either do nothing when I switch to auto and just act like it is still in loiter, or it will go up to the waypoint altitude, turn towards the ROI and then loiter there. 

I've done every different combination of waypoints i can think of as well as following the auto tutorial video 3DR has on youtube. I haven't had a chance to try from mission planner yet, only droid planner. I tried with both my phone and tablet and had the same results though.

Any ideas or help would be greatly appreciated. It sure would be nice if its just some simple thing i am messing up as opposed to having to reset to a clean slate and retune the thing.

Thanks and if i left any obvious things to try or critical info let me know!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • So after a bit of fiddling yesterday with the compass settings I tried setting a ROI again and it worked perfectly. I also did a little bit of Follow Me too. Very happy right now. Thank you guys for your help!

  • Hey guys thanks for the replys!

    I just installed 3.2 on my iris and will try it out tomorrow morning (After recalibrating of course!)

    My Droid planners are both 2.7.1 so i think that explains why i was trying to do the newer, simpler ROI mission and not seeing the option for the DO_SET_ROI. 

    I will report back tomorrow after some flights

  • Behavior of Region of Interest (ROI) differs between Arducopter 3.1 (which IRIS came out with) and Arducopter 3.2 (which IRIS+ is currently using). 

    Have a look here on more details: 

  • From my experiments with ROI in the past it depends on what firmware your PixHawk is running.

    I think you need 3.2 for a single ROI to work and there are two different ROI types, only one of which works.

    On 3.1 you have to add a ROI after each waypoint I think.

    Sorry I can't be more exact, as I don't have access to the software today, but the two commands are listed on:

    So have a look at the exact ROI type you are using and what Pixhawk firmware you are on:

This reply was deleted.