No right yaw

Radio calibration page see's full right yaw input but pixhawk doesn't or barely responds. If somebody could look at this log I would really appreciate it. 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • AHH!!! it's a Pixhawk that the reason I don't recognize the dididah ; I always starts as Richard describes too and add that always take off in stab, then try Alt hold, then pos hold or Loiter, then, if all looks well, RTL and finally Auto. On one copter I pluged incorrectly one ESc and the copter try to flip during the first test

  • Hi Richard. I am glad you have this figured out for your yaw. However I do have a question. What does it mean when the sound is dit dit dit dah? Like a "V" in morse code.  I had a very short flight on the Y6 and landed but it turned upside down I didn't have enough time to figure out if the sticks were right. I was in Stabilize mode and I thought I was in Loiter but found out I had started it in Stabilize. Which is great if I get this thing figured out.  It hovered ok but could not get it to react to my TX inputs (my learning curve for this Y6) So I am not sure if I have the radio setup properly. But after I straightened the props I could not get it to arm, it just started going DIT DIT DIT DAH. 

    • I have found it best to not start out in any mode that requires gps such as loiter. I almost always start out in alt hold. 

      One thing I do after setting up a new copter to confirm all is as it should be is arm it then hold on to it VERY carefully, with gloves and safety glasses, then just throttle it up enough so it feel's like it's lifting it's own weight. Then tilt it forward and sideways and you should feel it fighting that trying to keep it level. On one occasion it was opposite and most certainly would have been an instant crash. I had the props on wrong. You can also sort of notice if it vibrate more one way than the other and it's easy to narrow down which motor and prop is vibrating more than the rest. You can also use your TX and move the stick around to confirm it reacts as it should. Obviously you have to be very careful. I've had my son help me out with the TX stick so I can hold on with both hands.

      If it continues to beep and not arm your probably your gonna need to re-do some or all of the mandatory set up including calibrating the esc's.  At least that's been my experience. Let me know how it goes. Good luck!

    • Hi Richard, thanks for your input. I did start the flight in Stabilize mode however it would not arm until the GPS had a fix. Not sure if I had controls crossed or not the flight was a hover for about 15 seconds and then it started drifting so I slowly closed throttle and then tried to compensate for the drift which I think I gave it the wrong control. It did touch the ground and then rolled over due to the the way that it contacted the ground. Nothing to harm the Y6, folding props and a good inspection I found it ready to fly. That is when I changed batteries thinking that I had a low battery. the one that I changed out was a low battery that I grabbed thinking that It was fully charged. The weather is calling for windy days today and tomorrow (Sunday and Monday) So I will attempt another flight next week between the rain that is in our forecast. I found on You Tube a video explaining the various beeps and their meaning. The DIT DIT DIT Dah was saying that I did not have GPS or compass. All this has happened after I updated the FW. So not sure that the RC is totally correct, I will tie the Y6 down and try your method, I have tried that without props to see if the motors would speed up or down when tilted and with input from the TX. And the S-Buss form Futaba R7008SB seems to be working just fine. Will let you know after my next flight...jim

    • I know that sound it's usually when it detected a crash I think. It should go away after you power it up again

    • Jim, perhaps it help if you can take a video doing didididah and if your issue is different than this one perhaps you have more help if you open another specific post ;) and is isefull too if you have a log too, better enable all


    • Thanks, I found it last night  on You Tube It had all the Beeps and their meanings found it very helpful in my trouble shooting. It was saying that I had and issue with the GPS. Also I changed batteries thinking that I might have a voltage problem, Which I did, It was the battery that I changed out. It was reading 14.9 voltes and I did not know that until after going through the logs did I find that the fail safe was also going into effect. I will attempt another flight in the next few days as the weather here is quite windy and I need  a calm day to test and to auto tune. thanks for your reply Great help indeed.

  • GREAAAAATTTTT!!!!!! , I had similar issue on my old cuad but the symptom was pulsate in loiter, only one arm little twisted, it's give me a long headhache UFF!!

  • I changed the name of this thread it had nothing to do with the firmware install. It just coincided with that. 

  • Andy posted that it looked like RCIN rarely goes below 1500 yet APM P radio calibration page shows 892-2006. So it seems there is some issue with that not registering with the controller. Yet it shows on the radio calibration page so what the heck does that mean??!! 

This reply was deleted.