Pixhawk (Arduplane 3.2.3 ) dont spin motor


Need a help. Problem is follow: when I connecting my four servos and esc with motor directly to receiver, everything work. Than I try to re-connect, servos go to outputs 1,2,4 and esc with motor to 3. Receiver connects to Pixhawk through ppm encoder. Binding with controller (Flysky 9x) is good.

Then I disable failsafe checking and throttle (left stick) down and to the right. Hardware arming switch change to solid by pushing. Calibrated radio. In mission planner I can see proper reaction to stick moving. On subfolder FailSafe I can see "Radio IN" that pixhawk receive my signals from controller and can see that  "Servo/motor OUT" parallelly properly shows my movments.

My Pixhawk is arming, servos react ok , but motor and esc do emit nothing.    

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi all,

    I have the exact same problem. I have also ensured Pixhawk (Arduplane V3.7.1) is armed and I can also see the ch?ins and ch?outs moving with different values in Mission Planner so PX4FMU part is working fine. However, motors do not move. PX4IO is the problem. I have further followed instructions how to force an update of the PX4IO firmware from the PX4 website but still the same problem.

    However, I believe PX4IO firmware still is not properly installed because the bootloader file is not there. Also, I am unable to connect to Nutty Shell (NSH from Mission Planner ->Terminal even when disarmed) but can connect to Pixhawk just fine. I have also tried upgrading to the ArduPlane 3.8 beta version but same problem.

    Anyone know how I can have more granular control of what is happenning with PX4IO ? The QUpgrade software seems missing also.


    Warmest regards,


  • Hi I have the same problem that the pixhawk receives the tx throttle signal but the esc does not react

    if I connect the esc to the receiver directly its works fine.

    I struggled so much with this pixhawk (fake) that I bought another 3dr pixhawk that had no troubles

    But I still need to fix this fake pixhawk

    Is there anything I can do or is this one of that buy original lessons to be learned.

This reply was deleted.