Setting/Clearing Waypoints with Ch6

Ok I'm testing the learn mode by sitting in my house and using mission planner to readback the waypoints. Switching to learn mode and toggling the learn switch (ch 6) doesn't appear to do anything. I use Read WP to load the way points from the PixHawk to mission planner and nothing is there. If I create way points in mission planner and write them to the rover, then I can also read those back. Now if I switch to manual mode and toggle ch6, the way points are not erased, so I would assume it has something to do with the learn switch.

I have learn_ch = 6 (my radio is a 6 channel)
I have verified all 6 channels work as expected in the radio tuning page.
RC6 has a range of 964-2064 with a center point of 1514.
I have tried toggling low to high and high to low.
Ch5 is my mode switch and I can switch between manual, learning, and auto, verifying on the HUD.
GPS has a lock and shows the rover in the middle of my house on the mission planner screens.
Firmware is APM 3.x
I am able to drive the rover around in manual mode as expected.

Does the rover actually have to be moving to set waypoints?  I'm assuming it can just sit there and add a waypoint by toggling Ch6 while in learn mode.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Just for the sake of completion I'll post the solution here as well.  I looked through the source code today and realized that the parameter CH7_OPTION isn't really for CH7, it's for whatever channel you're using as the learn switch.  Since I don't have a channel 7, I had set this parameter to 0 (do nothing).  Now with that parameter = 1, I'm able to learn waypoints.

  • I have an active discussion at as well.  One user duplicated my setup using channel 6 for learning and was able to save waypoints, so it is doable.  Just have to find what that silly thing is that I'm missing.

    ArduPilot Open Source Autopilot
    The most advanced open source autopilot for use by both professionals and hobbyist. Supports multi-copters, planes, rovers, boats, helicopters, ante…
  • My best advice is to go to the rover form and ask. All my experience is flight related and I fly auto , preset waypoint missions for my line of work. I have a few customers that are in need of watercraft mapping drones for maping lakes so I will be again learning the Rover side of things.
    It's all the same just a bit different..something simple I'm sure.

    Sorry I couldn't help more then that.
    Without physically being there its hard to diagnose. I'm sure someone on the rover form will have an answer.
    Hope this helps
  • Went outside and toggled ch6 while driving in learn mode, then switched it to auto.  Still no waypoints.  Not sure if I should be toggling ch6 low-high-low or high-low-high.  Tried both ways, doesn't seem to matter.  I looked at the log files and I can see RCIN5 and 6 are moving as expected.  What else can I try?

  • But I do have a GPS fix and on the planner page of MP it shows the rover in the middle of my house.  I understand that without a GPS fix you can't learn waypoints.  I will still try outside a little later when it's not so hot. (Phoenix).


  • The point of Rodney's reply was that you wont have a GPS fix indoors, so there will be no valid data to store for a waypoint. Try placing the rover in the back yard with a clear view of the sky and try again.

  • For now I'm just trying to verify the switches are working.  When I'm ready to do a real mission, that will be outside on the proper course.

  • You will have to be outside and run your rover to the waypoints you want to learn. Remember your waypoints will only be accurate in open areas, you need an unobstructed view of the sky.
    If you want to set waypoints in advance for a mission then you do so in MP.
This reply was deleted.