Throttle setting for the Pixhawk

I'm not sure why, but I do not have full throttle when connected to my Pixhawk. The reason I say this is that when I am at half throttle all motors spinning (Y6, newest version firmware loaded), but when I place the flight mode switch to RTL my motors more than double the RPM.  I am running 4S 11AH Lipo and my motors are 400 KV. My radio is Futaba T14SG with Futaba R7008SB receiver connected via S-buss to the pixhawk. I have gone through the Parm's with a fine tooth comb. Cannot find anything out of the norm. This only happens when I switch from Stabilize to RTL. When I switch back from RTL to Stabilize my throttle drops back to where it was before making the  flight mode switch. But I cannot get the motors to run as fast as they did whilst in RTL mode. In fact from half throttle on to full throttle there is nothing but my stick movement on the TX, no increase in RPM. I'm not running props on this thing until I find out what the problem might be. Fear of this Y6 climbing to 10 kilometers or more just frightens me..As of today I have not flown this Y6. Has anyone experienced this problem and if so what did you do to correct?  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey Jim I don't known if you solved your problem yet but I saw your post looking for something else for myself so I joined DIY so I could help you out I had the exact thing going on too. I looked at your posted log file and sure enough there it was look at the THR_MAX, 80.00000 in your log when you install the firm ware for the first time it sets the THR_MAX, value to 80.00 the parameter is in config/tuning under extended tuning in mission planer the value should be 800 to 1000 for max value... my quad would not get off the ground with it like that. changed that and took care of it and like you said from stable to RTL motors like triple the speed...any way check it out that's what it is....


    • Hi Mark; Again thank you for joining DIY Drones, this is a great forum for helping resolve issues, I've help a few and now have caused one issue. I think that you were correct in your assessment on the THR_MAX. I just set it to 700 (it was my max) and I had more throttle. I will go through this once again and nail it down but you my friend have solved this issue. Now It is just fine-tuning and off I go.. Thanks again...

    • Hi Jim,I glad I could help you out I know sometimes It just takes a new pair of eyes to look at something to fugure it out. I like the fourm I have been here on and off over the past few months.I do alot of design and building with fixed wing and muti-rotors I have a Y-6 project also thats why your post caught my eye. I have APM 2.6 on it FireFLY6 it's a VTOL flying wing. You may have heard of it.. But the pixhawk I have is on a 2500 gram quad with camera (gopro 4).Thats how I knew about the max throttle setting. The param is acctualy under the config/tunning advanced params all the way at the bottom the scale is 800-1000. Anyway let me know how it flys shoud take wonderful pics with the canon...

    • Hi Mark; Yes I have heard of your FireFLY6 Just read a very good article about it.  Impressive design and impressive use of servos for the transformation to forward flight. But you will have to explain the NAZA that I thought I saw in one of the photos for stabilization. Very interesting indeed. Expert engineering to say the least.  Was that you in the article in "Rotor Drone" magazine? Again thanks for your help, I don't think that I  could have resolved the issue so quickly. You are right about THR_MAX being at the bottom of the advance params list. I missed it so many times. I am waiting for a cable from 3D Robotics to mount my 3D transmitter. But I really could fly anytime. I will post pictures as soon as I get the auto tune complete an knowing that it is a stable platform. 

    • Hi Mark;  I will reset this again. I though that I had set this parm once but over the last couple weeks trying to figure this out I might have reset this back to the start. Thank you for joining and thank you for your help I will try this after work this afternoon to see if this works. Will keep you posted..jim

    • Hey Jim,Yes if you use the reset default parameters the THR_MAX, value gets set to 80.00 but 80.00 wont fly anything of size. If you look at your THR_MAX and your THR_MIN, in your log file the values the max cant be less the min setting and they are (opps) I think the value range is 800-1000 but no lower then 800 anyway good luck my friend 

    • I had the same problem as Jim. After loading the Quad X it sets the THR_MAX to around 80. 

    • Hi Kenny; thanks so much for offering you input, it is valuable and Mark above in the postings zeroed in on it.. I came home after work and made the change, and I did find it was reset to 80.0 So no wonder it was not supplying  enough throttle. Thanks gain for your help....jim

  • Could one of these be in play?  Also I wonder if it simply acts differently sitting on the bench compared to flying? I had similar issue with amp-plane trying to set up RTL the throttle kept going to zero until I figured out until it's in the air moving it won't throttle up. That surely isn't the case with copter and stab mode though. It should just be a direct input from the TX no input from the controller at all.  



    • Hi Richard; I will recheck everything again. I will try this this afternoon after work and see where it stands. I remember setting these parms however since I've reset everything back to ground zero I will double check. Hope to have some good news later today..thanks again for your help...jim

This reply was deleted.