Gimbal control problems

Hey guys! I've been building my first RVjet for the past few weeks (slowly but surely), and I'm just about complete. The last thing I'm trying to do is control the gimbal and this has been problematic. Using an APM2.6 with PPM stream from an OpenLRSng RX. I just want to pass control thru, not use the stabilizing features. I tried that spare ports on the servo rail and also tried routing them to R10 & R11. Either way the servos go berserk, extremely jerky. I can tell the input I give makes a difference, but they have major twitching. I'm running the signal wires from R10 and R11 and getting power from the main output rail (as detailed in the wiki). I've tried other servos with the same results, so the problem seems with the APM, not the gimbal servos.

On my radio, running OpenTX, I've assigned the gimbal tilt and pan controls to ch 5&6. Is there a way to assign these RC channels 5&6 to R10&R11 without using the gimbal control interface in Mission Planner? Maybe this control interface is the issue, but maybe not.

Any ideas? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –