3DR Solo CLI - Command line

I wonder if someone can help me with this.  Recently, i purchased a 3DR Solo and decide to create some programming projects with its SDK.  Just starting off, i ran into issues already.  I have been trying to install the 3DR Solo CLI - command line, it seems the installation was fine. But i am having problem of when i type "solo info" or "solo wifi" to connect to the Solo, it just stuck at connecting.

solo info
solo wifi --name=<n> [--password=<p>]
solo flash (drone|controller|both) (latest|current|factory|<version>) [--clean]
solo flash --list
solo flash pixhawk <filename>
solo provision
solo resize
solo logs (download)
solo install-pip
solo install-smart
solo install-runit
solo video (acquire|restore)
solo script [<arg>...]

C:\Windows\system32>solo info
connecting to Solo and the Controller... <-------- this the part it stuck at for very long time!!!!!!

Traceback (most recent call last):
File "C:\Python27\Scripts\solo-script.py", line 9, in
load_entry_point('solo-cli==1.1.1', 'console_scripts', 'solo')()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 547, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2719, in load_entry_point
return ep.load()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2379, in load
return self.resolve()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2385, in resolve
module = import(self.module_name, fromlist=['name'], level=0)
File "C:\Python27\lib\site-packages\soloutils__main__.py", line 39, in
File "C:\Python27\lib\site-packages\soloutils\info.py", line 12, in main
controller = soloutils.connect_controller(await=True)
File "C:\Python27\lib\site-packages\soloutils__init__.py", line 56, in connect_controller
return connect('', await=await, silent=silent)
File "C:\Python27\lib\site-packages\soloutils__init_.py", line 33, in _connect
client.connect(ip, username='root', password='TjSDBkAu', timeout=5)
File "C:\Python27\lib\site-packages\paramiko\client.py", line 325, in connect
File "C:\Python27\lib\site-packages\paramiko\transport.py", line 488, in start_client
File "C:\Python27\lib\threading.py", line 621, in wait
File "C:\Python27\lib\threading.py", line 359, in wait
KeyboardInterrupt  <------ had to press ctrl+c to cancel


does it have something to do with line 621 and 359 of threading.py?  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you ever get connected?  If so how.  I have the same issue.  

  • Hello,

    I'm using window7, I had pipand pytjon 2.7 installed on my PC, at the window command window, I followed the README instruction  and did the following

    pip install https://github.com/3drobotics/solo-cli/archive/master.zip --no-cache-dir

    it came back saying

    Successfully installed solo-cli-1.2.0 

    When I entered "solo" at the command line, I got errors.(see attached file)

    How can I move forward after installation/



    • you don't have virtual environment installed!!!

      pip install virtualenv

    • thanks, However, still need help  connecting the solo

      My solo wifi name is SoloLink_pe, password is peter

      I tried the following

      solo wifi --name="SoloLink_pe" --password="peter"

      solo wifi --name=SoloLink_pe --password=peter

      solo wifi --name=  --password=peter

      All came back with 

      "connecting to the Controller..." and hung.

      What is the proper syntax for connecting the solo.


      PS, MAVProxy had no issue connecting to Solo.

    • I believe the problem is timeout. I can see the data going to solo, but solo is not quick enough to return the values.

      Does anyone have a work around?

    • 1.  Install only python27 and pip.  Make sure you dont have any other version of python or there is going to be conflict.  Make sure you add the path in env variable

      2.  dont use zip, use pip install git+https://gitHub.com/3drobotics/solo-cli //always current and updated

      3.  Dont use gitbash, well that depends, i like to use WinSCP for SSH, it works better and easier, i think

      4.  solo wifi --name=the name of your wifi connection of your house, NOT SOLO

      --password=the password of your wifi connection of your house, NOT SOLO

      example:  solo wifi --name=home321 --password=123456

      Solo command line utilities. Contribute to 3drobotics/solo-cli development by creating an account on GitHub.
    • I did have several versions of python but I uninstalled them all except 2.7. may be there are some mixup still there. I will have a clean win7 pc coming next week, I will try the procedures with a clean pc.

      BTW, I also tried the home wifi/password, when the following prompt showed up

      "(note: ensure you are connected to Solo's wifi network.)'

      I switch the connection to solo wifi,, solo responded with few beep, after another network switch, solo beep more then the rm error messages popped out (see attached file)


    • connect to Solo, type 'solo info' to see if you are connected, if information regarding your Solo is output to the screen, you are good to go, then from Solo Cli connect to wifi.  Make sure you are connected to Solo first.  

      your pic showed that the problem is with your wifi.  

    • Hello Peter,

      After few more tries, I finally got Solo info working. but still having the wifi issue because our wifi password has special characters eg & and %.I tried to put quotes around the password and still no luck. What is the correct way to enter the password that has special characters.

    • Hello Peter,

      You are very correct, solo nstall-runit is buggy. I had reboot several time and ran solo-install-smart few times. Finally got thru all the install. Before I could pop a cold one, solo wifi died. After calling 3DR support, Went thru controller pairing, and few tries of factory reset. Finally got solo back. Instead of a clean factory default, my wifi name and password still in solo. 3Dr tech had no explanation. So I took solo out, flew few batteries, did not see anything strange. Came back ran solo info, get the same responses as yesterday. So, apparently factory reset did not put Solo back to the state when I got it on day 1. Now I'm not sure should I move on with CLI .

This reply was deleted.